blob: c9059c9921ff338fa4e20ee9a21a7d2d334f4513 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Apache Portable Runtime (APR) library"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002
3DESCRIPTION = "Create and maintain software libraries that provide a predictable \
4and consistent interface to underlying platform-specific implementations."
5
Brad Bishopc342db32019-05-15 21:57:59 -04006HOMEPAGE = "http://apr.apache.org/"
7SECTION = "libs"
8DEPENDS = "util-linux"
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=4dfd4cd216828c8cae5de5a12f3844c8 \
12 file://include/apr_lib.h;endline=15;md5=823b3d1a7225df8f7b68a69c3c2b4c71"
13
14BBCLASSEXTEND = "native nativesdk"
15
16SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.bz2 \
17 file://run-ptest \
Brad Bishopc342db32019-05-15 21:57:59 -040018 file://0002-apr-Remove-workdir-path-references-from-installed-ap.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040019 file://0004-Fix-packet-discards-HTTP-redirect.patch \
20 file://0005-configure.in-fix-LTFLAGS-to-make-it-work-with-ccache.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040021 file://0007-explicitly-link-libapr-against-phtread-to-make-gold-.patch \
Brad Bishop00e122a2019-10-05 11:10:57 -040022 file://libtoolize_check.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050023 file://0001-Add-option-to-disable-timed-dependant-tests.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050024 file://0001-configure-Remove-runtime-test-for-mmap-that-can-map-.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040025 "
26
Patrick Williams864cc432023-02-09 14:54:44 -060027SRC_URI[sha256sum] = "75e77cc86776c030c0a5c408dfbd0bf2a0b75eed5351e52d5439fa1e5509a43e"
Brad Bishopc342db32019-05-15 21:57:59 -040028
Andrew Geissler82c905d2020-04-13 13:39:40 -050029inherit autotools-brokensep lib_package binconfig multilib_header ptest multilib_script
Brad Bishopc342db32019-05-15 21:57:59 -040030
31OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
32
33# Added to fix some issues with cmake. Refer to https://github.com/bmwcarit/meta-ros/issues/68#issuecomment-19896928
34CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes"
Patrick Williams92b42cb2022-09-03 06:53:57 -050035# Enable largefile
36CACHED_CONFIGUREVARS += "apr_cv_use_lfs64=yes"
37# Additional AC_TRY_RUN tests which will need to be cached for cross compile
38CACHED_CONFIGUREVARS += "apr_cv_epoll=yes epoll_create1=yes apr_cv_sock_cloexec=yes \
39 ac_cv_struct_rlimit=yes \
40 ac_cv_func_sem_open=yes \
41 apr_cv_process_shared_works=yes \
42 apr_cv_mutex_robust_shared=yes \
43 "
Brad Bishopc342db32019-05-15 21:57:59 -040044# Also suppress trying to use sctp.
45#
46CACHED_CONFIGUREVARS += "ac_cv_header_netinet_sctp_h=no ac_cv_header_netinet_sctp_uio_h=no"
47
Patrick Williams92b42cb2022-09-03 06:53:57 -050048# ac_cv_sizeof_struct_iovec is deduced using runtime check which will fail during cross-compile
49CACHED_CONFIGUREVARS += "${@['ac_cv_sizeof_struct_iovec=16','ac_cv_sizeof_struct_iovec=8'][d.getVar('SITEINFO_BITS') != '32']}"
50
Brad Bishopc342db32019-05-15 21:57:59 -040051CACHED_CONFIGUREVARS += "ac_cv_file__dev_zero=yes"
52
Patrick Williams92b42cb2022-09-03 06:53:57 -050053CACHED_CONFIGUREVARS:append:libc-musl = " ac_cv_strerror_r_rc_int=yes"
Brad Bishopc342db32019-05-15 21:57:59 -040054PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
Patrick Williams92b42cb2022-09-03 06:53:57 -050055PACKAGECONFIG:append:libc-musl = " xsi-strerror"
Brad Bishopc342db32019-05-15 21:57:59 -040056PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
Andrew Geissler82c905d2020-04-13 13:39:40 -050057PACKAGECONFIG[timed-tests] = "--enable-timed-tests,--disable-timed-tests,"
Patrick Williams92b42cb2022-09-03 06:53:57 -050058PACKAGECONFIG[xsi-strerror] = "ac_cv_strerror_r_rc_int=yes,ac_cv_strerror_r_rc_int=no,"
Brad Bishopc342db32019-05-15 21:57:59 -040059
Patrick Williams213cb262021-08-07 19:21:33 -050060do_configure:prepend() {
Brad Bishopc342db32019-05-15 21:57:59 -040061 # Avoid absolute paths for grep since it causes failures
62 # when using sstate between different hosts with different
63 # install paths for grep.
64 export GREP="grep"
65
66 cd ${S}
Brad Bishop00e122a2019-10-05 11:10:57 -040067 # The "2" means libtool version 2.
68 ./buildconf 2
Brad Bishopc342db32019-05-15 21:57:59 -040069}
70
Andrew Geissler82c905d2020-04-13 13:39:40 -050071MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/apr-1-config \
72 ${PN}-dev:${datadir}/build-1/apr_rules.mk"
73
Patrick Williams213cb262021-08-07 19:21:33 -050074FILES:${PN}-dev += "${libdir}/apr.exp ${datadir}/build-1/*"
Andrew Geissler595f6302022-01-24 19:11:47 +000075RDEPENDS:${PN}-dev += "bash libtool"
Brad Bishopc342db32019-05-15 21:57:59 -040076
Patrick Williams213cb262021-08-07 19:21:33 -050077RDEPENDS:${PN}-ptest += "libgcc"
Brad Bishop393846f2019-05-20 12:24:11 -040078
Brad Bishopc342db32019-05-15 21:57:59 -040079#for some reason, build/libtool.m4 handled by buildconf still be overwritten
80#when autoconf, so handle it again.
Patrick Williams213cb262021-08-07 19:21:33 -050081do_configure:append() {
Brad Bishopc342db32019-05-15 21:57:59 -040082 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/libtool.m4
83 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/apr_rules.mk
84}
85
Patrick Williams213cb262021-08-07 19:21:33 -050086do_install:append() {
Brad Bishopc342db32019-05-15 21:57:59 -040087 oe_multilib_header apr.h
88 install -d ${D}${datadir}/apr
89}
90
Patrick Williams213cb262021-08-07 19:21:33 -050091do_install:append:class-target() {
Andrew Geissler595f6302022-01-24 19:11:47 +000092 rm -f ${D}${datadir}/build-1/libtool
93 sed -i s,LIBTOOL=.*,LIBTOOL=libtool,g ${D}${datadir}/build-1/apr_rules.mk
Brad Bishopc342db32019-05-15 21:57:59 -040094 sed -i -e 's,${DEBUG_PREFIX_MAP},,g' \
95 -e 's,${STAGING_DIR_HOST},,g' ${D}${datadir}/build-1/apr_rules.mk
96 sed -i -e 's,${STAGING_DIR_HOST},,g' \
97 -e 's,APR_SOURCE_DIR=.*,APR_SOURCE_DIR=,g' \
98 -e 's,APR_BUILD_DIR=.*,APR_BUILD_DIR=,g' ${D}${bindir}/apr-1-config
99}
100
101SSTATE_SCAN_FILES += "apr_rules.mk libtool"
102
103SYSROOT_PREPROCESS_FUNCS += "apr_sysroot_preprocess"
104
105apr_sysroot_preprocess () {
106 d=${SYSROOT_DESTDIR}${datadir}/apr
107 install -d $d/
108 cp ${S}/build/apr_rules.mk $d/
109 sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk
110 sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk
Andrew Geissler595f6302022-01-24 19:11:47 +0000111 sed -i s,LIBTOOL=.*,LIBTOOL=libtool,g $d/apr_rules.mk
Brad Bishopc342db32019-05-15 21:57:59 -0400112 sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk
113 cp ${S}/build/mkdir.sh $d/
114 cp ${S}/build/make_exports.awk $d/
115 cp ${S}/build/make_var_export.awk $d/
Andrew Geissler595f6302022-01-24 19:11:47 +0000116 cp ${S}/libtool ${SYSROOT_DESTDIR}${datadir}/build-1/libtool
Brad Bishopc342db32019-05-15 21:57:59 -0400117}
118
119do_compile_ptest() {
120 cd ${S}/test
121 oe_runmake
122}
123
124do_install_ptest() {
125 t=${D}${PTEST_PATH}/test
126 mkdir -p $t/.libs
127 cp -r ${S}/test/data $t/
128 cp -r ${S}/test/.libs/*.so $t/.libs/
129 cp ${S}/test/proc_child $t/
130 cp ${S}/test/readchild $t/
131 cp ${S}/test/sockchild $t/
132 cp ${S}/test/sockperf $t/
133 cp ${S}/test/testall $t/
134 cp ${S}/test/tryread $t/
135}
136
137export CONFIG_SHELL="/bin/bash"