blob: c400462e02958926b7a924f9c8cc141824fed09b [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3LICENSE = "LGPL-2.1+"
Brad Bishopb809eb92019-09-18 06:27:43 -04004LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005SECTION = "net"
Brad Bishopb809eb92019-09-18 06:27:43 -04006
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007DEPENDS = "file"
8
Brad Bishop779d0ac2019-09-27 08:23:48 -04009SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz \
Brad Bishop779d0ac2019-09-27 08:23:48 -040010"
Brad Bishop868407c2019-11-04 13:24:47 -050011SRC_URI[md5sum] = "e28e04e3d3eca62f5754efb844d17812"
12SRC_URI[sha256sum] = "7e1f852723d099d4827d7ebde4d02dd00fd8da62149526fdb9fae058c5a60495"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
14inherit autotools lib_package pkgconfig gettext
15
16CFLAGS += "-pthread -D_REENTRANT"
17
18EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
19
20PACKAGECONFIG ?= "curl https"
21PACKAGECONFIG_append_class-target = "\
22 ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \
23"
24PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
25PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
26PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls,"
27
28do_compile_append() {
29 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
30}