blob: 019e327e0ccf88a4c8370e4d480be6490650e1a7 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "The PyPA recommended tool for installing Python packages"
2HOMEPAGE = "https://pypi.python.org/pypi/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e"
6
7DEPENDS += "python3 python3-setuptools-native"
8
Brad Bishop79641f22019-09-10 07:20:22 -04009SRC_URI[md5sum] = "f417444c66a0db1a82c8d9d2283a2f95"
10SRC_URI[sha256sum] = "e7a31f147974362e6c82d84b91c7f2bdf57e4d3163d3d454e6c3e71944d67135"
Brad Bishopc342db32019-05-15 21:57:59 -040011
12inherit pypi distutils3
13
14do_install_append() {
15 # Install as pip3 and leave pip2 as default
16 rm ${D}/${bindir}/pip
17}
18
19RDEPENDS_${PN} = "\
20 python3-compile \
21 python3-io \
22 python3-html \
23 python3-json \
24 python3-netserver \
25 python3-setuptools \
26 python3-unixadmin \
27 python3-xmlrpc \
Brad Bishop00e122a2019-10-05 11:10:57 -040028 python3-pickle \
Brad Bishopc342db32019-05-15 21:57:59 -040029"
30
31BBCLASSEXTEND = "native nativesdk"