blob: 465071560750a6468844d18e398a3d894e36f3e4 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
15 file://utils/ffsb-6.0-rc2/COPYING;md5=c46082167a314d785d012a244748d803 \
16"
17
18DEPENDS = "attr libaio libcap acl openssl zip-native"
19DEPENDS_append_libc-musl = " fts "
20EXTRA_OEMAKE_append_libc-musl = " LIBC=musl "
21
22# since ltp contains x86-64 assembler which uses the frame-pointer register,
23# set -fomit-frame-pointer x86-64 to handle cases where optimisation
24# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
25# earlier in CFLAGS, etc.
26CFLAGS_append_x86-64 = " -fomit-frame-pointer"
27
28CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
29CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
Brad Bishop96ff1982019-08-19 13:50:42 -040030SRCREV = "ac33ef87f0b9dc56533026435be3ea8c67ce86d2"
Brad Bishop19323692019-04-05 15:28:33 -040031
32SRC_URI = "git://github.com/linux-test-project/ltp.git \
Brad Bishop96ff1982019-08-19 13:50:42 -040033 file://0001-build-Add-option-to-select-libc-implementation.patch \
34 file://0002-kernel-controllers-Link-with-libfts-explicitly-on-mu.patch \
35 file://0003-Check-if-__GLIBC_PREREQ-is-defined-before-using-it.patch \
36 file://0004-guard-mallocopt-with-__GLIBC__.patch \
Brad Bishop96ff1982019-08-19 13:50:42 -040037 file://0006-rt_tgsigqueueinfo-disable-test-on-musl.patch \
38 file://0007-Fix-test_proc_kill-hanging.patch \
39 file://0008-testcases-network-nfsv4-acl-acl1.c-Security-fix-on-s.patch \
40 file://0009-open_posix_testsuite-mmap24-2-Relax-condition-a-bit.patch \
41 file://0010-shmctl01-don-t-use-hardcoded-index-0-for-SHM_STAT-te.patch \
42 file://0011-direct_io-diotest4-drop-MAP_FIXED.patch \
43 file://0012-getrlimit03-adjust-a-bit-of-code-to-compatiable-with.patch \
Brad Bishop08902b02019-08-20 09:16:51 -040044 file://0001-Add-configure-time-check-for-getdents-getdents64-API.patch \
45 file://0002-check-for-RES_USE_INET6-during-configure.patch \
Brad Bishopc68388fc2019-08-26 01:33:31 -040046 file://0001-syscalls-tgkill03-wait-for-defunct-tid-to-get-detach.patch \
47 file://0001-ustat02-Fix-EFAULT-in-32bit-compatibility-mode.patch \
Brad Bishop79641f22019-09-10 07:20:22 -040048 file://0001-cve-meltdown.c-Fix-kernel-symbol-finding.patch \
49 file://0001-testcases-use-python3-everywhere-to-run-python-scrip.patch \
50 file://0001-syscall-rt_sigtimedwait01-Fix-wrong-sigset-length-fo.patch \
Brad Bishop00e122a2019-10-05 11:10:57 -040051 file://0001-cve-2017-17052-Avoid-unsafe-exits-in-threads.patch \
Brad Bishop19323692019-04-05 15:28:33 -040052 "
53
54S = "${WORKDIR}/git"
55
56inherit autotools-brokensep
57
58TARGET_CC_ARCH += "${LDFLAGS}"
59
60export prefix = "/opt/ltp"
61export exec_prefix = "/opt/ltp"
62
63PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
64EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
65EXTRA_OECONF = " --with-power-management-testsuite --with-realtime-testsuite --with-open-posix-testsuite "
66# ltp network/rpc test cases ftbfs when libtirpc is found
67EXTRA_OECONF += " --without-tirpc "
68
69do_install(){
70 install -d ${D}/opt/ltp/
71 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
72
73 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
74 # as it lacks dependency on some perl moudle such as LWP::Simple
75 # And this script previously works as a tool for analyzing failures from LTP
76 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
77 # http://khack.osdl.org to retrieve ltp test results run on
78 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
79 rm -rf ${D}/opt/ltp/bin/STPfailure_report.pl
80
81 # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual
82 cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases
83}
84
85RDEPENDS_${PN} = "\
86 acl \
87 at \
88 attr \
89 bash \
90 cpio \
91 cronie \
92 curl \
93 e2fsprogs-mke2fs \
94 expect \
95 file \
96 gawk \
97 gzip \
98 iproute2 \
99 ldd \
100 libaio \
101 logrotate \
102 perl \
Brad Bishop79641f22019-09-10 07:20:22 -0400103 python3-core \
Brad Bishop19323692019-04-05 15:28:33 -0400104 procps \
105 quota \
106 unzip \
107 util-linux \
108 which \
109 tar \
110"
111
112FILES_${PN} += "/opt/ltp/* /opt/ltp/runtest/* /opt/ltp/scenario_groups/* /opt/ltp/testcases/bin/* /opt/ltp/testcases/bin/*/bin/* /opt/ltp/testscripts/* /opt/ltp/testcases/open_posix_testsuite/* /opt/ltp/testcases/open_posix_testsuite/conformance/* /opt/ltp/testcases/open_posix_testsuite/Documentation/* /opt/ltp/testcases/open_posix_testsuite/functional/* /opt/ltp/testcases/open_posix_testsuite/include/* /opt/ltp/testcases/open_posix_testsuite/scripts/* /opt/ltp/testcases/open_posix_testsuite/stress/* /opt/ltp/testcases/open_posix_testsuite/tools/* /opt/ltp/testcases/data/nm01/lib.a /opt/ltp/lib/libmem.a"
113
114# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
115INHIBIT_PACKAGE_STRIP_FILES = "/opt/ltp/testcases/bin/nm01 /opt/ltp/testcases/bin/ldd01"
116INSANE_SKIP_${PN} += "already-stripped staticdev"
117
118# Avoid file dependency scans, as LTP checks for things that may or may not
119# exist on the running system. For instance it has specific checks for
120# csh and ksh which are not typically part of OpenEmbedded systems (but
121# can be added via additional layers.)
122SKIP_FILEDEPS_${PN} = '1'