blob: 2597e4bae24840c059df7f6790ab82f2f12f2757 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Script to properly configure BT-HCI on Raspberry Pi"
2HOMEPAGE = "https://github.com/RPi-Distro/pi-bluetooth"
3SECTION = "kernel"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "\
6 file://debian/copyright;md5=6af8de3c8ee71f8e91e9b22f84ff2022 \
7"
8
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009SRC_URI = "\
10 git://github.com/RPi-Distro/pi-bluetooth \
11 file://0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch \
12"
Brad Bishop985dee92019-11-11 08:08:32 -050013SRCREV = "cbdbcb66bcc5b9af05f1a9fffe2254c872bb0ace"
Brad Bishop316dfdd2018-06-25 12:45:53 -040014
15S = "${WORKDIR}/git"
16
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017# hciuart.service replaces what was brcm43438.service
18inherit systemd
19SYSTEMD_SERVICE_${PN} = "\
20 hciuart.service \
21 bthelper@.service \
22"
23
Brad Bishop316dfdd2018-06-25 12:45:53 -040024inherit allarch
25
26do_install() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027 install -d ${D}${sysconfdir}/udev/rules.d
28 install -m 0644 ${S}/lib/udev/rules.d/* ${D}${sysconfdir}/udev/rules.d
29
Brad Bishop316dfdd2018-06-25 12:45:53 -040030 install -d ${D}${bindir}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031 install -m 0755 ${S}/usr/bin/bthelper ${D}${bindir}
Brad Bishop316dfdd2018-06-25 12:45:53 -040032 install -m 0755 ${S}/usr/bin/btuart ${D}${bindir}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033
34 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
35 install -d ${D}${systemd_system_unitdir}
36 install -m 0644 ${S}/debian/pi-bluetooth.bthelper@.service ${D}${systemd_system_unitdir}/bthelper@.service
37 install -m 0644 ${S}/debian/pi-bluetooth.hciuart.service ${D}${systemd_system_unitdir}/hciuart.service
38 fi
Brad Bishop316dfdd2018-06-25 12:45:53 -040039}
40
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080041FILES_${PN} = "\
42 ${bindir} \
43 ${sysconfdir} \
44 ${systemd_unitdir}/system \
45"
Brad Bishop870eb532020-01-06 09:44:45 -050046
47RDEPENDS_${PN} += " \
48 udev-rules-rpi \
49"