blob: 746c08be6e9b53a47f21c253fcabfaf305d4bb44 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SECTION = "console/utils"
2SUMMARY = "A free SOCKS server"
3DESCRIPTION = "Dante consists of a SOCKS server and a SOCKS client,\
4implementing RFC 1928 and related standards. It is a flexible product\
5that can be used to provide convenient and secure network\
6connectivity. Once installed, Dante can in most cases be made\
7transparent to clients, providing functionality somewhat similar to\
8what could be described as a non-transparent Layer 4 router."
9HOMEPAGE = "http://www.inet.no/dante/"
10
11LICENSE = "BSD-3-Clause"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050012LIC_FILES_CHKSUM = "file://LICENSE;md5=edd508404db7339042dfc861a3a690ad"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013
14SRC_URI = "https://www.inet.no/dante/files/dante-${PV}.tar.gz \
15 "
Andrew Geissler87f5cff2022-09-30 13:13:31 -050016SRC_URI[sha256sum] = "418a065fe1a4b8ace8fbf77c2da269a98f376e7115902e76cda7e741e4846a5d"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017
18# without --without-gssapi, config.log will contain reference to /usr/lib
19# as a consequence of GSSAPI path being set to /usr by default.
20# --with-gssapi-path=PATH specify gssapi path
21# --without-gssapi disable gssapi support
22# --enable-release build prerelease as full release
23EXTRA_OECONF += "--without-gssapi --sbindir=${bindir}"
24
Andrew Geissler87f5cff2022-09-30 13:13:31 -050025DEPENDS += "flex-native bison-native libpam libtirpc"
Brad Bishop8410d612019-11-25 09:40:59 -050026inherit autotools-brokensep features_check
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027
Andrew Geissler87f5cff2022-09-30 13:13:31 -050028CFLAGS += "-I${STAGING_INCDIR}/tirpc"
29LIBS += "-ltirpc"
30
Brad Bishop6e60e8b2018-02-01 10:27:11 -050031REQUIRED_DISTRO_FEATURES = "pam"
32
33EXTRA_AUTORECONF = "-I ${S}"
34
35PACKAGECONFIG[libwrap] = ",--disable-libwrap,tcp-wrappers,libwrap"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036
37PACKAGECONFIG ??= ""
38
Patrick Williams213cb262021-08-07 19:21:33 -050039do_install:append() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050040 install -d ${D}${sysconfdir}
41 cp ${S}/example/sock[sd].conf ${D}${sysconfdir}
42}
43
44PACKAGES =+ "${PN}-sockd ${PN}-libdsocks "
45
Patrick Williams213cb262021-08-07 19:21:33 -050046FILES:${PN}-libdsocks = "${libdir}/libdsocks.so"
47FILES:${PN}-sockd = "${bindir}/sockd ${sysconfdir}/sockd.conf"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050048
Patrick Williams213cb262021-08-07 19:21:33 -050049INSANE_SKIP:${PN}-libdsocks = "dev-elf"