blob: 7d37f41096494aea017a17751ee9171202964e7f [file] [log] [blame]
Andrew Geisslerd688a012020-09-18 13:36:00 -05001SUMMARY = "A suite for man in the middle attacks"
2HOMEPAGE = "https://github.com/Ettercap/ettercap"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-2.0-or-later"
Andrew Geisslerd688a012020-09-18 13:36:00 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6inherit cmake
7
8DEPENDS += "ethtool \
9 geoip \
10 librepo \
11 libnet \
12 libpcap \
13 ncurses \
14 openssl \
15 zlib \
16 bison-native \
17 flex-native \
18 "
19
Patrick Williams213cb262021-08-07 19:21:33 -050020RDEPENDS:${PN} += "bash ethtool libgcc"
Andrew Geisslerd688a012020-09-18 13:36:00 -050021
Andrew Geissler595f6302022-01-24 19:11:47 +000022SRC_URI = "gitsm://github.com/Ettercap/ettercap;branch=master;protocol=https"
Andrew Geisslerd688a012020-09-18 13:36:00 -050023
24SRCREV = "7281fbddb7da7478beb1d21e3cb105fff3778b31"
25
26S = "${WORKDIR}/git"
27
28EXTRA_OECMAKE = " \
29 -DCMAKE_SKIP_RPATH=TRUE \
30 -DBUNDLED_LIBS=ON \
31 -DENABLE_IPV6=ON \
32 -DENABLE_GTK=OFF \
33"
34
Andrew Geissler87f5cff2022-09-30 13:13:31 -050035CFLAGS += "-D_GNU_SOURCE"
Andrew Geisslerd688a012020-09-18 13:36:00 -050036# Replaces default encoding set (ISO-8859-1) with UTF-8 in ettercap
37# configuration file installed by the package.
38# It ensures that all characters are properly decoded and avoids
39# any fatal errors while running in text mode (-T).
Patrick Williams213cb262021-08-07 19:21:33 -050040do_install:append() {
Andrew Geisslerd688a012020-09-18 13:36:00 -050041 sed -i 's@utf8_encoding.*@utf8_encoding = "UTF-8"@g' \
42 ${D}/etc/ettercap/etter.conf
43}