blob: 516f3e2d9e5b8bd798d95d6a2f416e0b1ef2ce94 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Management Component Control Protocol utilities"
2HOMEPAGE = "http://www.github.com/CodeConstruct/mctp"
3SECTION = "net"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-only"
Andrew Geisslereff27472021-10-29 15:35:00 -05005
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4cc91856b08b094b4f406a29dc61db21"
7
Andrew Geissler595f6302022-01-24 19:11:47 +00008PV = "1.0+git${SRCPV}"
Andrew Geisslereff27472021-10-29 15:35:00 -05009
Andrew Geissler87f5cff2022-09-30 13:13:31 -050010SRCREV = "ae3a9162d6c5df0fa50abc34fc951dfd0e3d23c5"
Andrew Geissler595f6302022-01-24 19:11:47 +000011
12SRC_URI = "git://github.com/CodeConstruct/mctp;branch=main;protocol=https"
Andrew Geisslereff27472021-10-29 15:35:00 -050013
14S = "${WORKDIR}/git"
15
16inherit meson pkgconfig systemd
17
18PACKAGECONFIG ??= " \
19 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
20"
21
22# mctpd will only be built if pkg-config detects libsystemd; in which case
23# we'll want to declare the dep and install the service.
24PACKAGECONFIG[systemd] = ",,systemd,libsystemd"
25SYSTEMD_SERVICE:${PN} = "mctpd.service"
26
27do_install:append () {
28 if ${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'true', 'false', d)}; then
29 install -d ${D}${systemd_system_unitdir}
30 install -m 0644 ${S}/conf/mctpd.service \
31 ${D}${systemd_system_unitdir}/mctpd.service
Andrew Geissler595f6302022-01-24 19:11:47 +000032 install -d ${D}${datadir}/dbus-1/system.d
33 install -m 0644 ${S}/conf/mctpd-dbus.conf \
34 ${D}${datadir}/dbus-1/system.d/mctpd.conf
Andrew Geisslereff27472021-10-29 15:35:00 -050035 fi
36}
Andrew Geissler595f6302022-01-24 19:11:47 +000037
38FILES:${PN} += " \
39 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', \
40 '${datadir}/dbus-1/system.d/mctpd.conf', '', d)} \
41"