blob: 4cfe2ecca32619fdf0897a5576e61864de671656 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "A self-extracting archiving tool for Unix systems, in 100% shell script."
2DESCRIPTION = "\
3 makeself.sh is a small shell script that generates a self-extractable \
4 compressed tar archive from a directory. The resulting file appears as \
5 a shell script (many of those have a .run suffix), and can be launched as is.\
6"
7HOMEPAGE = "https://makeself.io/"
8LICENSE = "GPL-2.0-only"
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
11SRC_URI = "\
Andrew Geissler87f5cff2022-09-30 13:13:31 -050012 git://github.com/megastep/${BPN}.git;protocol=https;branch=master \
Patrick Williams92b42cb2022-09-03 06:53:57 -050013"
14
15SRCREV = "5742be6410bfad2c619fb1e98bf795e8fa0913c7"
16
17S = "${WORKDIR}/git"
18
19do_configure[noexec] = "1"
20do_compile[noexec] = "1"
21
22do_install() {
23 install -d ${D}${bindir}
Patrick Williams92b42cb2022-09-03 06:53:57 -050024 install -m 0755 ${S}/makeself.sh ${D}${bindir}/
25 install -m 0755 ${S}/makeself-header.sh ${D}${bindir}/
26}
27
28BBCLASSEXTEND = "native"