blob: 74a09e7bf8cfcf67baca70abed3568aea0d44dc2 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "A Perl module that checks whether a particular C library and its headers are available"
2DESCRIPTION = "This module provides a way of checking whether a particular library \
3and its headers are available, by attempting to compile a simple program and \
4link against it."
5HOMEPAGE = "https://metacpan.org/pod/Devel::CheckLib"
6SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Brad Bishopc342db32019-05-15 21:57:59 -04008
9LIC_FILES_CHKSUM = "file://README;md5=7911cdbb572d25c5f2e2ea17f669efc2"
10
11SRC_URI = "https://cpan.metacpan.org/modules/by-module/Devel/Devel-CheckLib-${PV}.tar.gz \
12 file://0001-CheckLib.pm-don-t-execute-the-binary.patch \
13"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050014SRC_URI[sha256sum] = "869d38c258e646dcef676609f0dd7ca90f085f56cf6fd7001b019a5d5b831fca"
Brad Bishopc342db32019-05-15 21:57:59 -040015
16S = "${WORKDIR}/Devel-CheckLib-${PV}"
17
18inherit cpan
19
Andrew Geissler615f2f12022-07-15 14:00:58 -050020do_install:append() {
21 # update interpreter on shebang line
22 # since old version env doesn't support multiple arguments, replace option
23 # '-w' with 'use warnings;'
24 sed -i -e "s:^#!.*:#!/usr/bin/env perl:" \
25 -e "/use strict;/ause warnings;" ${D}${bindir}/use-devel-checklib
26}
27
Brad Bishopc342db32019-05-15 21:57:59 -040028BBCLASSEXTEND="native"