blob: 4fefd5169b67b6b1237dc45ef55e08a5b43eb354 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Linux SCSi tools to service maintain disk storage devices"
2DESCRIPTION = "scsirastools were designed to add to the Serviceability of \
3 SCSI devices under Linux so that the system does not have \
4 to be rebooted or taken out of service to perform common \
5 maintenance or service functions. It handles SCSI, \
6 Linux SW RAID, SAS, SATA, and USB devices via SCSI emulation."
7HOMEPAGE = "http://scsirastools.sourceforge.net/"
Brad Bishop2d39a062019-10-28 08:33:36 -04008LICENSE = "BSD-3-Clause"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009LIC_FILES_CHKSUM = "file://COPYING;md5=687ea108478d26152ae46eb29d9d1545"
10
11DEPENDS += "groff-native"
12
13SRC_URI = "http://prdownloads.sourceforge.net/scsirastools/scsirastools-${PV}.tar.gz \
14 file://mdadm.patch;apply=no \
15 file://print-format.patch \
16"
17SRC_URI[md5sum] = "6271a61b2ce40aaf33ef61775148cda1"
18SRC_URI[sha256sum] = "e7b997e75decb06a650c42c35cd63d0c94c34e39cf133c723337b0eeabbfdf6a"
19
20inherit autotools update-rc.d
21
22# mdadm Makefile has CC set to gcc, hence override CC to ${CC}
Andrew Geissler87f5cff2022-09-30 13:13:31 -050023EXTRA_OEMAKE += "CC='${CC}' CFLAGS='${CFLAGS} -D_LARGEFILE64_SOURCE=1' sbindir=${base_sbindir}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024
Patrick Williams213cb262021-08-07 19:21:33 -050025do_configure:append() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026 oe_runmake -C mdadm.d mdadm-1.3.0
27 patch -p0 < ${WORKDIR}/mdadm.patch
28}
29INITSCRIPT_PACKAGES = "${PN}-diskmon ${PN}-raidmon"
Patrick Williams213cb262021-08-07 19:21:33 -050030INITSCRIPT_NAME:${PN}-diskmon = "sgdisk"
31INITSCRIPT_PARAMS:${PN}-diskmon = "defaults 80 20"
32INITSCRIPT_NAME:${PN}-raidmon = "sgraid"
33INITSCRIPT_PARAMS:${PN}-raidmon = "defaults 80 20"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050034
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080035PACKAGES =+ "${PN}-diskmon"
36PACKAGES =+ "${PN}-raidmon"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050037
Patrick Williams213cb262021-08-07 19:21:33 -050038RPROVIDES:${PN}-dbg += "${PN}-diskmon-dbg ${PN}-raidmon-dbg"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050039
Patrick Williams213cb262021-08-07 19:21:33 -050040FILES:${PN}-diskmon = "${sbindir}/sgdiskmon ${sysconfdir}/init.d/sgdisk"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050041
Patrick Williams213cb262021-08-07 19:21:33 -050042FILES:${PN}-raidmon = "${sbindir}/sgraidmon ${sysconfdir}/init.d/sgraid"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050043
Patrick Williams213cb262021-08-07 19:21:33 -050044RDEPENDS:${PN} += "bash"
45RDEPENDS:${PN}-diskmon += "${PN} bash"
46RDEPENDS:${PN}-raidmon += "${PN} bash"