blob: 62004ac4409298d3962addcb9f1310a3461dd47c [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "The GNU Compact Disc Input and Control library (libcdio) contains a library for CD-ROM and CD image access."
2HOMEPAGE = "http://www.gnu.org/software/libcdio/"
3SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-3.0-or-later"
Brad Bishopc342db32019-05-15 21:57:59 -04005LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
Andrew Geissler595f6302022-01-24 19:11:47 +00007SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.bz2 \
8 file://0001-Fix-a-few-Werror-format-security-errors-with-mvprint.patch \
9 "
Brad Bishopc342db32019-05-15 21:57:59 -040010
11SRC_URI[md5sum] = "aa7629e8f73662a762f64c444b901055"
12SRC_URI[sha256sum] = "8550e9589dbd594bfac93b81ecf129b1dc9d0d51e90f9696f1b2f9b2af32712b"
13
14inherit autotools pkgconfig
15
16PACKAGECONFIG ??= "cdda-player"
17PACKAGECONFIG[cdda-player] = "--with-cdda-player,--without-cdda-player,ncurses"
18PACKAGECONFIG[cddb] = "--enable-cddb,--disable-cddb,libcddb"
19PACKAGECONFIG[vcd-info] = "--enable-vcd-info,--disable-vcd-info,vcdimager"
20
Andrew Geissler87f5cff2022-09-30 13:13:31 -050021# add -D_LARGEFILE64_SOURCE for 32bit targets
22CFLAGS += "${@['-D_LARGEFILE64_SOURCE',''][d.getVar('SITEINFO_BITS') != '32']}"
23
Brad Bishopc342db32019-05-15 21:57:59 -040024PACKAGES += "${PN}-utils"
25
Patrick Williams213cb262021-08-07 19:21:33 -050026FILES:${PN} = "${libdir}/${BPN}${SOLIB}"
27FILES:${PN}-utils = "${bindir}/*"
Brad Bishopc342db32019-05-15 21:57:59 -040028
29python libcdio_split_packages() {
30 libdir = d.expand('${libdir}')
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000031 do_split_packages(d, libdir, r'^lib(.*)\.so\..*', 'lib%s', 'libcdio %s library', extra_depends='', allow_links=True)
Brad Bishopc342db32019-05-15 21:57:59 -040032}
33
34PACKAGESPLITFUNCS =+ "libcdio_split_packages"