blob: c83181cfea014e8f51cf874e3b9578982bb105e5 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "[Boost::ext].SML (State Machine Language)"
2DESCRIPTION = "Your scalable C++14 one header only State Machine Library with no dependencies"
3AUTHOR = "Krzysztof Jusiak"
4HOMEPAGE = "https://github.com/boost-ext/sml"
5BUGTRACKER = "https://github.com/boost-ext/sml/issues"
6SECTION = "libs"
7LICENSE = "BSL-1.0"
8LIC_FILES_CHKSUM = "file://LICENSE.md;md5=e4224ccaecb14d942c71d31bef20d78c"
9
10DEPENDS += "boost qemu-native"
11
Andrew Geissler87f5cff2022-09-30 13:13:31 -050012PV = "1.1.6"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000013
14SRC_URI = "git://github.com/boost-ext/sml.git;protocol=https;branch=master"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050015SRCREV = "23e9a24e434cac9922039cbb43ca54ab70bef72c"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000016
17S = "${WORKDIR}/git"
18
19inherit cmake
20
21# Building benchmarks takes a lot of time and requires additional headers (euml2.hpp)
Patrick Williams03907ee2022-05-01 06:28:52 -050022# Building examples fail with gcc-12
23EXTRA_OECMAKE:append = " -DSML_BUILD_BENCHMARKS:bool=OFF -DSML_BUILD_EXAMPLES=OFF"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000024
25# [boost::ext].XML is a header only C++ library, so the main package will be empty.
26ALLOW_EMPTY:${PN} = "1"
27
28BBCLASSEXTEND = "nativesdk"