blob: 2f8af9aa3f4db550aee03226c4ddb3196cc12405 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "mcelog daemon accounts memory and some other errors in various ways."
2DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \
3and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \
4and should run on all Linux systems that need error handling."
5HOMEPAGE = "https://mcelog.org/"
6SECTION = "System Environment/Base"
7
Patrick Williams45852732022-04-02 08:58:32 -05008SRC_URI = "\
9 git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http;;branch=master \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050010 file://0001-client-Include-string.h-form-mem-function-prototypes.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +000011 file://run-ptest \
Andrew Geissler9aee5002022-03-30 16:27:02 +000012"
13
Andrew Geissler87f5cff2022-09-30 13:13:31 -050014SRCREV = "b8dfb1fa34eb627a03adfb315326a29ec51214b3"
Andrew Geissler9aee5002022-03-30 16:27:02 +000015
16LICENSE = "GPL-2.0-only"
17LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
18
19S = "${WORKDIR}/git"
20
21inherit autotools-brokensep ptest
22
23COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
24
25do_install:append() {
26 install -d ${D}${sysconfdir}/cron.hourly
27 install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
28 sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron
29}
30
31do_install_ptest() {
32 install -d ${D}${PTEST_PATH}
33 cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH}
34 sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test
35}
36
37RDEPENDS:${PN}-ptest += "make bash mce-inject"