blob: 01ccef51242cdd407bd19762d8ff8635098dd1ce [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A portable version of the mg maintained by the OpenBSD team"
2HOMEPAGE = "http://homepage.boetes.org/software/mg/"
3LICENSE = "PD"
Andrew Geissler87f5cff2022-09-30 13:13:31 -05004LIC_FILES_CHKSUM = "file://version.c;md5=43616508f42ab3fdb082c5f932bd2eb4"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005DEPENDS = "ncurses libbsd"
6SECTION = "console/editors"
7
Andrew Geissler87f5cff2022-09-30 13:13:31 -05008SRCREV = "ea58e622fad20622ac0b723d021baaaf5dc0eb49"
Andrew Geissler595f6302022-01-24 19:11:47 +00009SRC_URI = "git://github.com/hboetes/mg;branch=master;protocol=https \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010 file://0001-fileio-Include-sys-param.h-for-MAXNAMLEN.patch \
11 file://0002-fileio-Define-DEFFILEMODE-if-platform-is-missing.patch \
12 "
Patrick Williams213cb262021-08-07 19:21:33 -050013SRC_URI:append:libc-musl = "\
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014 file://0001-Undefine-REGEX-for-musl-based-systems.patch \
15 "
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050016
17S = "${WORKDIR}/git"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018
19# CFLAGS isn't in EXTRA_OEMAKE, as the makefile picks it up via ?=
20EXTRA_OEMAKE = "\
21 'CC=${CC}' \
22 'LDFLAGS=${LDFLAGS}' \
23 \
24 'prefix=${prefix}' \
25 'bindir=${bindir}' \
26 'libdir=${libdir}' \
27 'includedir=${includedir}' \
28 'mandir=${mandir}' \
29 'PKG_CONFIG=pkg-config' \
30"
31
32CFLAGS += "-I${STAGING_INCDIR}/bsd"
33
34do_install () {
35 oe_runmake install DESTDIR=${D}
36}
37
38inherit pkgconfig