blob: 747a57e814b3f47265002915ead9e0896bbc2745 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "Google Authentication Library"
2HOMEPAGE = "https://github.com/googleapis/google-auth-library-python"
3AUTHOR = "Google Cloud Platform"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6
7inherit pypi setuptools3
8
Andrew Geissler87f5cff2022-09-30 13:13:31 -05009SRC_URI[sha256sum] = "516e6623038b81430dd062a1a25ecd24f173d7c15cdf4e48a9e78bc87e97aeec"
Patrick Williams92b42cb2022-09-03 06:53:57 -050010
11RDEPENDS:${PN} += "\
12 ${PYTHON_PN}-asyncio \
13 ${PYTHON_PN}-datetime \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-json \
16 ${PYTHON_PN}-logging \
17 ${PYTHON_PN}-netclient \
18 ${PYTHON_PN}-numbers \
19"
20
21RDEPENDS:${PN} += "\
22 ${PYTHON_PN}-aiohttp \
23 ${PYTHON_PN}-cachetools \
24 ${PYTHON_PN}-pyasn1-modules \
25 ${PYTHON_PN}-rsa \
26 ${PYTHON_PN}-six \
27"