blob: ce4f05dbedce9eff0b28506a1499aa2eb400cd2a [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python."
2HOMEPAGE = "https://www.h5py.org/"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c"
6
Andrew Geissler78b72792022-06-14 06:47:25 -05007SRC_URI[sha256sum] = "3fcf37884383c5da64846ab510190720027dca0768def34dd8dcb659dbe5cbf3"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008
9SRC_URI:append = " \
10 file://0001-setup_build.py-avoid-absolute-path.patch \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050011 file://0001-fix-wrong-file-driver-version.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +000012 "
13
14inherit pkgconfig pypi setuptools3
15
16BBCLASSEXTEND = "native"
17
18DEPENDS = "python3-pkgconfig-native \
19 python3-cython-native \
20 python3-numpy-native \
21 python3-six-native \
22 hdf5-native \
23 python3 \
24 hdf5 \
25 "
26
27RDEPENDS:${PN} = "python3-numpy \
28 python3-six \
29 python3-json \
30 "
31
Andrew Geissler87f5cff2022-09-30 13:13:31 -050032export HDF5_VERSION="1.13.2"