blob: 84154641ffd77aa3e6518f56fec5344abe5e8456 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A libudev binding"
2
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "LGPL-2.1-or-later"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00004LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
5
Andrew Geissler87f5cff2022-09-30 13:13:31 -05006SRC_URI[sha256sum] = "b2a3afe1c99ea751f8296652557eac559874da2a1b1ec0625178706ec5a345f3"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007
8inherit pypi setuptools3
9
10do_configure:prepend() {
11 sed -i "/import pyudev/d" ${S}/setup.py
12 sed -i "s/str(pyudev.__version__)/'${PV}'/g" ${S}/setup.py
13}
14
15RDEPENDS:${PN} = "\
16 ${PYTHON_PN}-ctypes \
17 ${PYTHON_PN}-misc \
18 ${PYTHON_PN}-six \
19 ${PYTHON_PN}-threading \
20 ${PYTHON_PN}-fcntl \
21 libudev \
22"
23
24BBCLASSEXTEND = "native nativesdk"