blob: 5f3986d8a38bc443574ef7aa65fdd8e97ef90686 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY:${PN}-dev = "Development files for manipulating RPM packages"
9DESCRIPTION:${PN}-dev = "This package contains the RPM C library and header files. These \
10development files will simplify the process of writing programs that \
11manipulate RPM packages and databases. These files are intended to \
12simplify the process of creating graphical package managers or any \
13other tools that need an intimate knowledge of RPM packages in order \
14to function."
15
16SUMMARY:python3-rpm = "Python bindings for apps which will manupulate RPM packages"
17DESCRIPTION:python3-rpm = "The python3-rpm package contains a module that permits applications \
18written in the Python programming language to use the interface \
19supplied by the RPM Package Manager libraries."
20
21HOMEPAGE = "http://www.rpm.org"
22
23# libraries are also LGPL - how to express this?
24LICENSE = "GPL-2.0-only"
25LIC_FILES_CHKSUM = "file://COPYING;md5=c4eec0c20c6034b9407a09945b48a43f"
26
Andrew Geissler87f5cff2022-09-30 13:13:31 -050027SRC_URI = "git://github.com/rpm-software-management/rpm;branch=rpm-4.18.x;protocol=https \
Patrick Williams92b42cb2022-09-03 06:53:57 -050028 file://environment.d-rpm.sh \
29 file://0001-Do-not-add-an-unsatisfiable-dependency-when-building.patch \
30 file://0001-Do-not-read-config-files-from-HOME.patch \
31 file://0001-When-cross-installing-execute-package-scriptlets-wit.patch \
32 file://0001-Do-not-reset-the-PATH-environment-variable-before-ru.patch \
33 file://0002-Add-support-for-prefixing-etc-from-RPM_ETCCONFIGDIR-.patch \
34 file://0001-Do-not-hardcode-lib-rpm-as-the-installation-path-for.patch \
35 file://0001-Add-a-color-setting-for-mips64_n32-binaries.patch \
36 file://0001-perl-disable-auto-reqs.patch \
37 file://0016-rpmscript.c-change-logging-level-around-scriptlets-t.patch \
38 file://0001-lib-transaction.c-fix-file-conflicts-for-MIPS64-N32.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050039 file://0001-docs-do-not-build-manpages-requires-pandoc.patch \
40 file://0001-build-pack.c-do-not-insert-payloadflags-into-.rpm-me.patch \
41 file://0001-configure.ac-add-linux-gnux32-variant-to-triplet-han.patch \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050042 file://fifofix.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050043 "
44
45PE = "1"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050046SRCREV = "ea0d77c52e176e2876fdb1d07ad41e9e2635a93e"
Patrick Williams92b42cb2022-09-03 06:53:57 -050047
48S = "${WORKDIR}/git"
49
50DEPENDS = "lua libgcrypt file popt xz bzip2 elfutils python3"
51DEPENDS:append:class-native = " file-replacement-native bzip2-replacement-native"
52
53inherit autotools gettext pkgconfig python3native
54export PYTHON_ABI
55
56AUTOTOOLS_AUXDIR = "${S}/build-aux"
57
58# OE-core patches autoreconf to additionally run gnu-configize, which fails with this recipe
59EXTRA_AUTORECONF:append = " --exclude=gnu-configize"
60
61# Vendor is detected differently on x86 and aarch64 hosts and can feed into target packages
62EXTRA_OECONF:append = " --enable-python --with-crypto=libgcrypt --with-vendor=pc"
63EXTRA_OECONF:append:libc-musl = " --disable-nls --disable-openmp"
64
65# --sysconfdir prevents rpm from attempting to access machine-specific configuration in sysroot/etc; we need to have it in rootfs
66# --localstatedir prevents rpm from writing its database to native sysroot when building images
67# Forcibly disable plugins for native/nativesdk, as the inhibit and prioreset
68# plugins both behave badly inside builds.
69EXTRA_OECONF:append:class-native = " --sysconfdir=/etc --localstatedir=/var --disable-plugins"
70EXTRA_OECONF:append:class-nativesdk = " --sysconfdir=/etc --disable-plugins"
71
72BBCLASSEXTEND = "native nativesdk"
73
74PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'inhibit', '', d)} sqlite zstd"
75# The inhibit plugin serves no purpose outside of the target
76PACKAGECONFIG:remove:class-native = "inhibit"
77PACKAGECONFIG:remove:class-nativesdk = "inhibit"
78
79PACKAGECONFIG[imaevm] = "--with-imaevm,,ima-evm-utils"
80PACKAGECONFIG[inhibit] = "--enable-inhibit-plugin,--disable-inhibit-plugin,dbus"
81PACKAGECONFIG[rpm2archive] = "--with-archive,--without-archive,libarchive"
82PACKAGECONFIG[sqlite] = "--enable-sqlite=yes,--enable-sqlite=no,sqlite3"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050083PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
Patrick Williams92b42cb2022-09-03 06:53:57 -050084PACKAGECONFIG[ndb] = "--enable-ndb,--disable-ndb"
85PACKAGECONFIG[bdb-ro] = "--enable-bdb-ro,--disable-bdb-ro"
86PACKAGECONFIG[zstd] = "--enable-zstd=yes,--enable-zstd=no,zstd"
87
88ASNEEDED = ""
89
90# Direct rpm-native to read configuration from our sysroot, not the one it was compiled in
91# libmagic also has sysroot path contamination, so override it
92
93WRAPPER_TOOLS = " \
94 ${bindir}/rpm \
95 ${bindir}/rpm2archive \
96 ${bindir}/rpm2cpio \
97 ${bindir}/rpmbuild \
98 ${bindir}/rpmdb \
99 ${bindir}/rpmgraph \
100 ${bindir}/rpmkeys \
101 ${bindir}/rpmsign \
102 ${bindir}/rpmspec \
103 ${libdir}/rpm/rpmdeps \
104"
105
106do_configure:prepend() {
107 mkdir -p ${S}/build-aux
108}
109
110do_install:append:class-native() {
111 for tool in ${WRAPPER_TOOLS}; do
112 test -x ${D}$tool && create_wrapper ${D}$tool \
113 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
114 RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE} \
115 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
116 RPM_NO_CHROOT_FOR_SCRIPTS=1
117 done
118}
119
120do_install:append:class-nativesdk() {
121 for tool in ${WRAPPER_TOOLS}; do
122 test -x ${D}$tool && create_wrapper ${D}$tool \
123 RPM_CONFIGDIR='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir'), d.getVar('bindir'))}/rpm \
124 RPM_ETCCONFIGDIR='$'{RPM_ETCCONFIGDIR-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir'), d.getVar('bindir'))}/..} \
125 MAGIC='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir'), d.getVar('bindir'))}/misc/magic.mgc \
126 RPM_NO_CHROOT_FOR_SCRIPTS=1
127 done
128
129 rm -rf ${D}/var
130
131 mkdir -p ${D}${SDKPATHNATIVE}/environment-setup.d
132 install -m 644 ${WORKDIR}/environment.d-rpm.sh ${D}${SDKPATHNATIVE}/environment-setup.d/rpm.sh
133}
134
135# Rpm's make install creates var/tmp which clashes with base-files packaging
136do_install:append:class-target() {
137 rm -rf ${D}/var
138}
139do_install:append:class-nativesdk() {
140 rm -rf ${D}${SDKPATHNATIVE}/var
141}
142
143do_install:append () {
144 sed -i -e 's:${HOSTTOOLS_DIR}/::g' \
145 ${D}/${libdir}/rpm/macros
146
147}
148
149FILES:${PN} += "${libdir}/rpm-plugins/*.so \
150 "
151FILES:${PN}:append:class-nativesdk = " ${SDKPATHNATIVE}/environment-setup.d/rpm.sh"
152
153FILES:${PN}-dev += "${libdir}/rpm-plugins/*.la \
154 "
155PACKAGE_BEFORE_PN += "${PN}-build ${PN}-sign ${PN}-archive"
156
157RRECOMMENDS:${PN} += "rpm-sign rpm-archive"
158
159FILES:${PN}-build = "\
160 ${bindir}/rpmbuild \
161 ${bindir}/gendiff \
162 ${bindir}/rpmspec \
163 ${libdir}/librpmbuild.so.* \
164 ${libdir}/rpm/brp-* \
165 ${libdir}/rpm/check-* \
166 ${libdir}/rpm/debugedit \
167 ${libdir}/rpm/sepdebugcrcfix \
168 ${libdir}/rpm/find-debuginfo.sh \
169 ${libdir}/rpm/find-lang.sh \
170 ${libdir}/rpm/*provides* \
171 ${libdir}/rpm/*requires* \
172 ${libdir}/rpm/*deps* \
173 ${libdir}/rpm/*.prov \
174 ${libdir}/rpm/*.req \
175 ${libdir}/rpm/config.* \
176 ${libdir}/rpm/mkinstalldirs \
177 ${libdir}/rpm/macros.p* \
178 ${libdir}/rpm/fileattrs/* \
179"
180
181FILES:${PN}-sign = "\
182 ${bindir}/rpmsign \
183 ${libdir}/librpmsign.so.* \
184"
185
186FILES:${PN}-archive = "\
187 ${bindir}/rpm2archive \
188"
189
190PACKAGES += "python3-rpm"
191PROVIDES += "python3-rpm"
192FILES:python3-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm/*"
193
194RDEPENDS:${PN}-build = "bash perl python3-core"
195
196PACKAGE_PREPROCESS_FUNCS += "rpm_package_preprocess"
197
198# Do not specify a sysroot when compiling on a target.
199rpm_package_preprocess () {
200 sed -i -e 's:--sysroot[^ ]*::g' \
201 ${PKGD}/${libdir}/rpm/macros
202}
203
204SSTATE_HASHEQUIV_FILEMAP = " \
205 populate_sysroot:*/rpm/macros:${TMPDIR} \
206 populate_sysroot:*/rpm/macros:${COREBASE} \
207 "