blob: 83f3c3f46ef95f8245680195a23d67f9a00bf2af [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Check - unit testing framework for C code"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "It features a simple interface for defining unit tests, \
3putting little in the way of the developer. Tests are run in a separate \
4address space, so both assertion failures and code errors that cause \
5segmentation faults or other signals can be caught. Test results are \
6reportable in the following: Subunit, TAP, XML, and a generic logging format."
Andrew Geissler82c905d2020-04-13 13:39:40 -05007HOMEPAGE = "https://libcheck.github.io/check/"
8SECTION = "devel"
9
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000010LICENSE = "LGPL-2.1-or-later"
Andrew Geissler82c905d2020-04-13 13:39:40 -050011LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=2d5025d4aa3495befef8f17206a5b0a1"
12
Andrew Geissler87f5cff2022-09-30 13:13:31 -050013SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/check-${PV}.tar.gz \
Andrew Geissler82c905d2020-04-13 13:39:40 -050014 file://not-echo-compiler-info-to-check_stdint.h.patch"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050015SRC_URI[sha256sum] = "a8de4e0bacfb4d76dd1c618ded263523b53b85d92a146d8835eb1a52932fa20a"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050016GITHUB_BASE_URI = "https://github.com/libcheck/check/releases/"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18S = "${WORKDIR}/check-${PV}"
19
Andrew Geissler87f5cff2022-09-30 13:13:31 -050020inherit autotools pkgconfig texinfo github-releases
Andrew Geissler82c905d2020-04-13 13:39:40 -050021
22CACHED_CONFIGUREVARS += "ac_cv_path_AWK_PATH=${bindir}/gawk"
23
Patrick Williams213cb262021-08-07 19:21:33 -050024RREPLACES:${PN} = "check (<= 0.9.5)"
Andrew Geissler82c905d2020-04-13 13:39:40 -050025
Andrew Geissler615f2f12022-07-15 14:00:58 -050026do_install:append:class-native() {
27 create_cmdline_shebang_wrapper ${D}${bindir}/checkmk
28}
Andrew Geissler82c905d2020-04-13 13:39:40 -050029BBCLASSEXTEND = "native nativesdk"
30
31PACKAGES =+ "checkmk"
32
Patrick Williams213cb262021-08-07 19:21:33 -050033FILES:checkmk = "${bindir}/checkmk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050034
Patrick Williams213cb262021-08-07 19:21:33 -050035RDEPENDS:checkmk = "gawk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050036