blob: e6e3ef07ade5baca60e14f5f5b086e2398c97a69 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Library for reading and editing the meta-data of popular audio formats"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Platform-independent library (tested on Windows/Linux) for reading and writing metadata in media files, including video, audio, and photo formats. This is a convenient one-stop-shop to present or tag all your media collection, regardless of which format/container these might use. You can read/write the standard or more common tags/properties of a media, or you can also create and retrieve your own custom tags."
Brad Bishop6e60e8b2018-02-01 10:27:11 -05003SECTION = "libs/multimedia"
4HOMEPAGE = "http://taglib.github.io/"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "LGPL-2.1-only | MPL-1.1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c \
7 file://COPYING.MPL;md5=bfe1f75d606912a4111c90743d6c7325 \
8 file://taglib/audioproperties.h;beginline=1;endline=24;md5=9df2c7399519b7310568a7c55042ecee"
9
10DEPENDS = "zlib"
11
Andrew Geissler95ac1b82021-03-31 14:34:31 -050012SRC_URI = "http://taglib.github.io/releases/${BP}.tar.gz"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013
Andrew Geissler95ac1b82021-03-31 14:34:31 -050014SRC_URI[md5sum] = "4313ed2671234e029b7af8f97c84e9af"
15SRC_URI[sha256sum] = "7fccd07669a523b07a15bd24c8da1bbb92206cb19e9366c3692af3d79253b703"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016
Andrew Geissler87f5cff2022-09-30 13:13:31 -050017UPSTREAM_CHECK_URI = "https://taglib.org/"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018
19BINCONFIG = "${bindir}/taglib-config"
20
21inherit cmake pkgconfig binconfig-disabled
22
23PACKAGES =+ "${PN}-c"
Patrick Williams213cb262021-08-07 19:21:33 -050024FILES:${PN}-c = "${libdir}/libtag_c.so.*"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025
26EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
27 -DCMAKE_DISABLE_FIND_PACKAGE_Boost=TRUE \
28 -DHAVE_BOOST_BYTESWAP=FALSE \
29 -DCMAKE_CXX_STANDARD=11 \
30 -DCMAKE_CXX_STANDARD_REQUIRED=OFF \
31 -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
32"
33CXXFLAGS += "-std=c++11"
34
Patrick Williams213cb262021-08-07 19:21:33 -050035do_configure:prepend () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036 rm -f ${S}/admin/ltmain.sh
37 rm -f ${S}/admin/libtool.m4.in
38}
39
40# without -fPIC depending packages failed with many error like:
41# | <...>/ld: error: <...>/usr/lib/libtag.a(modfilebase.cpp.o): requires unsupported dynamic reloc R_ARM_THM_MOVW_ABS_NC; recompile with -fPIC
42CXXFLAGS += "-fPIC"