Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Module::Runtime - runtime module handling" |
| 2 | DESCRIPTION = "The functions exported by this module deal with runtime \ |
| 3 | handling of Perl modules, which are normally handled at compile time. This \ |
| 4 | module avoids using any other modules, so that it can be used in low-level \ |
| 5 | infrastructure. \ |
| 6 | The parts of this module that work with module names apply the same syntax \ |
| 7 | that is used for barewords in Perl source. In principle this syntax can vary \ |
| 8 | between versions of Perl, and this module applies the syntax of the Perl on \ |
| 9 | which it is running. In practice the usable syntax hasn't changed yet, but \ |
| 10 | there's a good chance of it changing in Perl 5.18. \ |
| 11 | The functions of this module whose purpose is to load modules include \ |
| 12 | workarounds for three old Perl core bugs regarding require. These workarounds \ |
| 13 | are applied on any Perl version where the bugs exist, except for a case where \ |
| 14 | one of the bugs cannot be adequately worked around in pure Perl." |
| 15 | SECTION = "libs" |
| 16 | |
| 17 | HOMEPAGE = "http://search.cpan.org/~zefram/Module-Runtime/" |
| 18 | |
| 19 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 20 | LIC_FILES_CHKSUM = "file://README;beginline=36;endline=44;md5=9416434672a57853d6181f3da9094963" |
| 21 | |
| 22 | SRCNAME = "Module-Runtime" |
| 23 | SRC_URI = "${CPAN_MIRROR}/authors/id/Z/ZE/ZEFRAM/${SRCNAME}-${PV}.tar.gz" |
| 24 | SRC_URI[md5sum] = "d3d47222fa2e3dfcb4526f6cc8437b20" |
| 25 | SRC_URI[sha256sum] = "68302ec646833547d410be28e09676db75006f4aa58a11f3bdb44ffe99f0f024" |
| 26 | |
| 27 | UPSTREAM_CHECK_REGEX = "Module\-Runtime\-(?P<pver>(\d+\.\d+)).tar" |
| 28 | |
| 29 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 30 | |
| 31 | inherit cpan |
| 32 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 33 | RDEPENDS:${PN} = " perl-module-test-more \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 34 | perl-module-strict \ |
| 35 | " |
| 36 | |
| 37 | BBCLASSEXTEND = "native" |