Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 1 | SUMMARY = "LibTomCrypt is a public domain open source cryptographic toolkit" |
| 2 | HOMEPAGE = "https://www.libtom.net/LibTomCrypt" |
| 3 | SECTION = "libs" |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 4 | # Unlicense isn't very accurate for this revision, it was WTFPL in 0.18.0-rc1: |
| 5 | # https://github.com/libtom/libtomcrypt/commit/77e31fb6a980212e90b9a50f116dc5a7bd91e527 |
| 6 | # then updated to dual license PD and WTFPL also in 0.18.0-rc1: |
| 7 | # https://github.com/libtom/libtomcrypt/commit/412b2ee1fccc3a0df58f93f372c90d6d0f93bfc9 |
| 8 | # and then updated again to Unlicense after the 0.18.2 tag (it's only in develop branch): |
| 9 | # https://github.com/libtom/libtomcrypt/commit/3630bee6fc0f73dd9c7923fd43f8ae15a2c0fb70 |
| 10 | # but keep using Unlicense to avoid triggering people with WTFPL license: |
| 11 | # https://groups.google.com/g/libtom/c/17Z7xkECULM |
| 12 | # and this comment can be removed next time libtomcrypt is updated |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 13 | LICENSE = "Unlicense" |
| 14 | LIC_FILES_CHKSUM = "file://LICENSE;md5=71baacc459522324ef3e2b9e052e8180" |
| 15 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 16 | DEPENDS = "libtool-cross" |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 17 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 18 | SRC_URI = "git://github.com/libtom/libtomcrypt.git;protocol=https;branch=master \ |
| 19 | file://CVE-2019-17362.patch \ |
| 20 | " |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 21 | |
| 22 | SRCREV = "7e7eb695d581782f04b24dc444cbfde86af59853" |
| 23 | |
| 24 | S = "${WORKDIR}/git" |
| 25 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 26 | inherit pkgconfig |
| 27 | |
| 28 | PACKAGECONFIG ??= "ltm" |
| 29 | PACKAGECONFIG[ltm] = ",,libtommath" |
| 30 | |
| 31 | CFLAGS += "${@bb.utils.contains('PACKAGECONFIG', 'ltm', '-DUSE_LTM -DLTM_DESC', '', d)}" |
| 32 | |
| 33 | EXTRA_OEMAKE = "'PREFIX=${prefix}' 'DESTDIR=${D}' 'LIBPATH=${libdir}' 'CFLAGS=${CFLAGS}'" |
| 34 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 35 | do_compile() { |
| 36 | oe_runmake -f makefile.shared |
| 37 | } |
| 38 | |
| 39 | do_install() { |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 40 | oe_runmake -f makefile.shared install |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 41 | } |