blob: 0fd187f1b892d008f27601b0855e41999a9022c4 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Netfilter Tables userspace utillites"
2SECTION = "net"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d1a78fdd879a263a5e0b42d1fc565e79"
5
6DEPENDS = "libmnl libnftnl bison-native \
7 ${@bb.utils.contains('PACKAGECONFIG', 'mini-gmp', '', 'gmp', d)}"
8
9# Ensure we reject the 0.099 version by matching at least two dots
10UPSTREAM_CHECK_REGEX = "nftables-(?P<pver>\d+(\.\d+){2,}).tar.bz2"
11
12SRC_URI = "http://www.netfilter.org/projects/nftables/files/${BP}.tar.bz2"
Andrew Geissler89770b02020-06-13 10:40:47 -050013SRC_URI[sha256sum] = "f2c1957eabc370057c4576b8f33a71d91a6ad019b8b335abafe61c9c42cc7e16"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15inherit autotools manpages pkgconfig
16
17PACKAGECONFIG ??= "python readline"
18PACKAGECONFIG[json] = "--with-json, --without-json, jansson"
19PACKAGECONFIG[manpages] = "--enable-man-doc, --disable-man-doc, asciidoc-native"
20PACKAGECONFIG[mini-gmp] = "--with-mini-gmp, --without-mini-gmp"
21PACKAGECONFIG[python] = "--enable-python --with-python-bin=${PYTHON}, --with-python-bin="", python3"
22PACKAGECONFIG[readline] = "--with-cli=readline, --without-cli, readline"
23PACKAGECONFIG[xtables] = "--with-xtables, --without-xtables, iptables"
24
25inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
26
27RRECOMMENDS_${PN} += "kernel-module-nf-tables"
28
29PACKAGES =+ "${PN}-python"
30FILES_${PN}-python = "${nonarch_libdir}/${PYTHON_DIR}"
31RDEPENDS_${PN}-python = "python3-core python3-json"