blob: 02c541b4c2c769b5aad7dae04b103537c00e8200 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Multidicts are useful for working with HTTP headers, URL query args etc."
2HOMEPAGE = "https://github.com/aio-libs/multidict/"
Andrew Geissler2ee498a2020-05-29 15:52:06 -05003
Brad Bishop26bdd442019-08-16 17:08:17 -04004LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e74c98abe0de8f798ca609137f9cef4a"
6
Andrew Geissler89770b02020-06-13 10:40:47 -05007SRC_URI[md5sum] = "40b6ca77171ac8af55f7aa60049f3cdf"
8SRC_URI[sha256sum] = "fbb77a75e529021e7c4a8d4e823d88ef4d23674a202be4f5addffc72cbb91430"
Brad Bishop26bdd442019-08-16 17:08:17 -04009
Andrew Geissler2ee498a2020-05-29 15:52:06 -050010inherit pypi setuptools3 ptest
Andrew Geissler82c905d2020-04-13 13:39:40 -050011
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS_${PN}-ptest += " \
17 ${PYTHON_PN}-pytest \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
Andrew Geissler2ee498a2020-05-29 15:52:06 -050024
25BBCLASSEXTEND = "native nativesdk"