Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Matchbox lightweight window manager" |
| 2 | HOMEPAGE = "http://matchbox-project.org" |
| 3 | BUGTRACKER = "http://bugzilla.yoctoproject.org/" |
| 4 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 5 | LICENSE = "GPL-2.0-or-later" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://src/wm.h;endline=21;md5=a7e844465edbcf79c282369f93caa835 \ |
| 7 | file://src/main.c;endline=21;md5=3e5d9f832b527b0d72dbe8e3c4c60b95 \ |
| 8 | file://src/wm.c;endline=21;md5=8dc9d24477d87ef5dfbc2e4927146aab" |
| 9 | |
| 10 | SECTION = "x11/wm" |
| 11 | DEPENDS = "libmatchbox virtual/libx11 libxext libxrender startup-notification expat gconf libxcursor libxfixes" |
| 12 | |
| 13 | # SRCREV tagged 1.2.2 |
| 14 | SRCREV = "27da947e7fbdf9659f7e5bd1e92af92af6c03970" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 15 | SRC_URI = "git://git.yoctoproject.org/matchbox-window-manager;branch=master \ |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 16 | file://0001-Fix-build-with-gcc-10.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 17 | file://kbdconfig" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 21 | inherit autotools pkgconfig features_check |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 22 | # depends on virtual/libx11 |
| 23 | REQUIRED_DISTRO_FEATURES = "x11" |
| 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | FILES:${PN} = "${bindir}/* \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 26 | ${datadir}/matchbox \ |
| 27 | ${sysconfdir}/matchbox \ |
| 28 | ${datadir}/themes/blondie/matchbox \ |
| 29 | ${datadir}/themes/Default/matchbox \ |
| 30 | ${datadir}/themes/MBOpus/matchbox" |
| 31 | |
| 32 | EXTRA_OECONF = " --enable-startup-notification \ |
| 33 | --disable-xrm \ |
| 34 | --enable-expat \ |
| 35 | --with-expat-lib=${STAGING_LIBDIR} \ |
| 36 | --with-expat-includes=${STAGING_INCDIR}" |
| 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | do_install:prepend() { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 39 | install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig |
| 40 | } |