Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU Project parser generator (yacc replacement)" |
| 2 | DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \ |
| 3 | an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \ |
| 4 | grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \ |
| 5 | little trouble." |
| 6 | HOMEPAGE = "http://www.gnu.org/software/bison/" |
| 7 | LICENSE = "GPLv3" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 9 | SECTION = "devel" |
| 10 | DEPENDS = "bison-native flex-native" |
| 11 | |
| 12 | SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | file://add-with-bisonlocaledir.patch \ |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 14 | file://0001-Use-mapped-file-name-for-symbols.patch \ |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 15 | " |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "e8c53bc5bc396d636622d0f25e31ca92fd53f00b09629f13ef540d564a6b31ab" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | |
| 18 | # No point in hardcoding path to m4, just use PATH |
| 19 | EXTRA_OECONF += "M4=m4" |
| 20 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 21 | inherit autotools gettext texinfo |
| 22 | |
| 23 | # The automatic m4 path detection gets confused, so force the right value |
Andrew Geissler | b7d2861 | 2020-07-24 16:15:54 -0500 | [diff] [blame] | 24 | acpaths = "-I ./m4" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 25 | |
| 26 | do_compile_prepend() { |
| 27 | for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done |
| 28 | } |
| 29 | |
| 30 | do_install_append_class-native() { |
| 31 | create_wrapper ${D}/${bindir}/bison \ |
| 32 | BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison |
| 33 | } |
| 34 | do_install_append_class-nativesdk() { |
| 35 | create_wrapper ${D}/${bindir}/bison \ |
| 36 | BISON_PKGDATADIR=${datadir}/bison |
| 37 | } |
| 38 | BBCLASSEXTEND = "native nativesdk" |