blob: c8bbea4454fc03747ccd23c568d3e03e32b33ff2 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013 file://add-with-bisonlocaledir.patch \
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060014 file://0001-Use-mapped-file-name-for-symbols.patch \
Andrew Geissler4ed12e12020-06-05 18:00:41 -050015 "
Andrew Geisslerd1e89492021-02-12 15:35:20 -060016SRC_URI[sha256sum] = "e8c53bc5bc396d636622d0f25e31ca92fd53f00b09629f13ef540d564a6b31ab"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18# No point in hardcoding path to m4, just use PATH
19EXTRA_OECONF += "M4=m4"
20
Andrew Geissler82c905d2020-04-13 13:39:40 -050021inherit autotools gettext texinfo
22
23# The automatic m4 path detection gets confused, so force the right value
Andrew Geisslerb7d28612020-07-24 16:15:54 -050024acpaths = "-I ./m4"
Andrew Geissler82c905d2020-04-13 13:39:40 -050025
26do_compile_prepend() {
27 for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
28}
29
30do_install_append_class-native() {
31 create_wrapper ${D}/${bindir}/bison \
32 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
33}
34do_install_append_class-nativesdk() {
35 create_wrapper ${D}/${bindir}/bison \
36 BISON_PKGDATADIR=${datadir}/bison
37}
38BBCLASSEXTEND = "native nativesdk"