Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "File synchronization tool" |
| 2 | HOMEPAGE = "http://rsync.samba.org/" |
| 3 | BUGTRACKER = "http://rsync.samba.org/bugzilla.html" |
| 4 | SECTION = "console/network" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 5 | # GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0) |
| 6 | LICENSE = "GPLv3+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 8 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 9 | DEPENDS = "popt" |
| 10 | |
| 11 | SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \ |
| 12 | file://rsyncd.conf \ |
| 13 | file://makefile-no-rebuild.patch \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI[md5sum] = "1581a588fde9d89f6bc6201e8129afaf" |
| 17 | SRC_URI[sha256sum] = "55cc554efec5fdaad70de921cd5a5eeb6c29a95524c715f3bbf849235b0800c0" |
| 18 | |
| 19 | inherit autotools |
| 20 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 21 | PACKAGECONFIG ??= "acl attr \ |
| 22 | ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \ |
| 23 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 25 | PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl," |
| 26 | PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr," |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 27 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 28 | |
| 29 | # By default, if crosscompiling, rsync disables a number of |
| 30 | # capabilities, hardlinking symlinks and special files (i.e. devices) |
| 31 | CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes" |
| 32 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 33 | EXTRA_OEMAKE = 'STRIP=""' |
| 34 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 35 | # rsync 3.0 uses configure.sh instead of configure, and |
| 36 | # makefile checks the existence of configure.sh |
| 37 | do_configure_prepend () { |
| 38 | rm -f ${S}/configure ${S}/configure.sh |
| 39 | } |
| 40 | |
| 41 | do_configure_append () { |
| 42 | cp -f ${S}/configure ${S}/configure.sh |
| 43 | } |
| 44 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 45 | do_install_append() { |
| 46 | install -d ${D}${sysconfdir} |
| 47 | install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir} |
| 48 | } |
| 49 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 50 | BBCLASSEXTEND = "native" |