blob: 4c9e157a22d98a7f0d4818df83d9f55ad5494b10 [file] [log] [blame]
Brad Bishopba470942017-07-21 22:05:22 -04001# WARNING!
2#
3# These modifications to os-release disable the bitbake parse
4# cache (for the os-release recipe only). Before copying
5# and pasting into another recipe ensure it is understood
6# what that means!
7
Brad Bishop05ce9c52015-11-19 22:06:41 -06008def run_git(d, cmd):
Brad Bishop7019fbe2017-07-21 21:47:44 -04009 try:
10 oeroot = d.getVar('COREBASE', True)
Patrick Williamsbc442de2020-11-18 12:29:25 -060011 return bb.process.run(("export PSEUDO_DISABLED=1; " +
12 "git --work-tree %s --git-dir %s/.git %s")
Brad Bishop7019fbe2017-07-21 21:47:44 -040013 % (oeroot, oeroot, cmd))[0].strip('\n')
Patrick Williamsbc442de2020-11-18 12:29:25 -060014 except Exception as e:
15 bb.warn("Unexpected exception from 'git' call: %s" % e)
Brad Bishop7019fbe2017-07-21 21:47:44 -040016 pass
Brad Bishopbe861802015-11-11 13:56:17 -050017
Adriana Kobylak8c5ef9e2021-01-14 15:37:48 -060018VERSION_ID := "${@run_git(d, 'describe --dirty')}"
Patrick Williams46d9de32020-11-17 15:42:09 -060019VERSION = "${@'-'.join(d.getVar('VERSION_ID').split('-')[0:2])}"
Brad Bishop05ce9c52015-11-19 22:06:41 -060020
Patrick Williams46d9de32020-11-17 15:42:09 -060021BUILD_ID := "${@run_git(d, 'describe --abbrev=0')}"
22OPENBMC_TARGET_MACHINE = "${MACHINE}"
Brad Bishop05ce9c52015-11-19 22:06:41 -060023
Joseph Reynolds268247a2018-12-05 16:49:22 -060024OS_RELEASE_FIELDS_append = " BUILD_ID OPENBMC_TARGET_MACHINE"
Brad Bishopba470942017-07-21 22:05:22 -040025
26# Ensure the git commands run every time bitbake is invoked.
27BB_DONT_CACHE = "1"
Brad Bishope384d0c2017-07-24 20:24:28 -040028
29# Make os-release available to other recipes.
30SYSROOT_DIRS_append = " ${sysconfdir}"