Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
Andrew Jeffery | 274f96a | 2020-04-03 16:20:51 +1030 | [diff] [blame] | 2 | |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 3 | SRC_URI:remove = "file://${BPN}.conf" |
Andrew Jeffery | 274f96a | 2020-04-03 16:20:51 +1030 | [diff] [blame] | 4 | SRC_URI += "file://server.ttyVUART0.conf" |
Andrew Jeffery | 1688b15 | 2020-02-17 15:34:34 +1030 | [diff] [blame] | 5 | |
| 6 | install_concurrent_console_config() { |
| 7 | # Install configuration for the servers and clients. Keep commandline |
| 8 | # compatibility with previous configurations by defaulting to not |
| 9 | # specifying a socket-id for VUART0/2200 |
| 10 | install -m 0755 -d ${D}${sysconfdir}/${BPN} |
| 11 | |
| 12 | # Remove the default client configuration as we don't to define a |
| 13 | # socket-id for the 2200 console |
| 14 | rm -f ${D}${sysconfdir}/${BPN}/client.2200.conf |
| 15 | |
| 16 | # However, now link to /dev/null as a way of not specifying a |
| 17 | # socket-id while having a configuration file present. We need to |
| 18 | # provide a configuration path to meet the requirements of the packaged |
| 19 | # unit file. |
| 20 | ln -sr ${D}/dev/null ${D}${sysconfdir}/${BPN}/client.2200.conf |
| 21 | |
| 22 | # We need to populate socket-id for remaining consoles |
| 23 | install -m 0644 ${WORKDIR}/client.2201.conf ${D}${sysconfdir}/${BPN}/ |
| 24 | |
| 25 | # Install configuration for remaining servers - the base recipe |
| 26 | # installs the configuration for the first. |
| 27 | install -m 0644 ${WORKDIR}/server.ttyVUART1.conf ${D}${sysconfdir}/${BPN}/ |
| 28 | } |
| 29 | |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 30 | SRC_URI:append:p10bmc = " file://client.2201.conf" |
| 31 | SRC_URI:append:p10bmc = " file://server.ttyVUART1.conf" |
Andrew Jeffery | 1688b15 | 2020-02-17 15:34:34 +1030 | [diff] [blame] | 32 | |
Abhishek Patel | 14d29c2 | 2021-09-29 22:44:11 -0500 | [diff] [blame] | 33 | REGISTERED_SERVICES:${PN}:append:p10bmc = " obmc_console_hypervisor:tcp:2201:" |
Andrew Jeffery | 1688b15 | 2020-02-17 15:34:34 +1030 | [diff] [blame] | 34 | |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 35 | SYSTEMD_SERVICE:${PN}:append:p10bmc = " obmc-console-ssh@2200.service \ |
Andrew Jeffery | 1688b15 | 2020-02-17 15:34:34 +1030 | [diff] [blame] | 36 | obmc-console-ssh@2201.service \ |
| 37 | " |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 38 | SYSTEMD_SERVICE:${PN}:remove:p10bmc = "obmc-console-ssh.socket" |
Andrew Jeffery | 1688b15 | 2020-02-17 15:34:34 +1030 | [diff] [blame] | 39 | |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 40 | FILES:${PN}:remove:p10bmc = "${systemd_system_unitdir}/obmc-console-ssh@.service.d/use-socket.conf" |
Andrew Jeffery | 1688b15 | 2020-02-17 15:34:34 +1030 | [diff] [blame] | 41 | |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 42 | EXTRA_OECONF:append:p10bmc = " --enable-concurrent-servers" |
Andrew Jeffery | 1688b15 | 2020-02-17 15:34:34 +1030 | [diff] [blame] | 43 | |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 44 | do_install:append:p10bmc() { |
Andrew Jeffery | 1688b15 | 2020-02-17 15:34:34 +1030 | [diff] [blame] | 45 | install_concurrent_console_config |
| 46 | } |
Andrew Jeffery | 35c33cc | 2020-04-02 15:29:34 +1030 | [diff] [blame] | 47 | |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 48 | SRC_URI:append:witherspoon-tacoma = " file://client.2201.conf" |
| 49 | SRC_URI:append:witherspoon-tacoma = " file://server.ttyVUART1.conf" |
Andrew Jeffery | 35c33cc | 2020-04-02 15:29:34 +1030 | [diff] [blame] | 50 | |
Abhishek Patel | 14d29c2 | 2021-09-29 22:44:11 -0500 | [diff] [blame] | 51 | REGISTERED_SERVICES:${PN}:append:witherspoon-tacoma = " obmc_console_hypervisor:tcp:2201:" |
Andrew Jeffery | 35c33cc | 2020-04-02 15:29:34 +1030 | [diff] [blame] | 52 | |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 53 | SYSTEMD_SERVICE:${PN}:append:witherspoon-tacoma = " obmc-console-ssh@2200.service \ |
Andrew Jeffery | 35c33cc | 2020-04-02 15:29:34 +1030 | [diff] [blame] | 54 | obmc-console-ssh@2201.service \ |
| 55 | " |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 56 | SYSTEMD_SERVICE:${PN}:remove:witherspoon-tacoma = "obmc-console-ssh.socket" |
Andrew Jeffery | 35c33cc | 2020-04-02 15:29:34 +1030 | [diff] [blame] | 57 | |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 58 | FILES:${PN}:remove:witherspoon-tacoma = "${systemd_system_unitdir}/obmc-console-ssh@.service.d/use-socket.conf" |
Andrew Jeffery | 35c33cc | 2020-04-02 15:29:34 +1030 | [diff] [blame] | 59 | |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 60 | EXTRA_OECONF:append:witherspoon-tacoma = " --enable-concurrent-servers" |
Andrew Jeffery | 35c33cc | 2020-04-02 15:29:34 +1030 | [diff] [blame] | 61 | |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 62 | do_install:append:witherspoon-tacoma() { |
Andrew Jeffery | 35c33cc | 2020-04-02 15:29:34 +1030 | [diff] [blame] | 63 | install_concurrent_console_config |
| 64 | } |