blob: 21445922861198d2b6de21ab97ef1eaa53b10fca [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Regular expressions library"
2DESCRIPTION = "Oniguruma is a modern and flexible regular expressions library. \
3It encompasses features from different regular expression \
4implementations that traditionally exist in different languages. \
5Character encoding can be specified per regular expression object."
6HOMEPAGE = "https://github.com/kkos/oniguruma"
7LICENSE = "BSD-2-Clause"
Patrick Williams8dd68482022-10-04 07:57:18 -05008LIC_FILES_CHKSUM = "file://COPYING;md5=e6365c225bb5cc4321d0913f0baffa04"
Brad Bishope42b3e32020-01-15 22:08:42 -05009
10SRC_URI = "\
11 https://github.com/kkos/oniguruma/releases/download/v${PV}/${BP}.tar.gz \
12 file://0001-build-don-t-link-against-host-system-libraries.patch \
Patrick Williams8dd68482022-10-04 07:57:18 -050013 file://0002-build-enable-serial-tests-automake-option-for-ptest.patch \
Brad Bishope42b3e32020-01-15 22:08:42 -050014 file://run-ptest \
15"
16
Patrick Williams8dd68482022-10-04 07:57:18 -050017SRC_URI[sha256sum] = "28cd62c1464623c7910565fb1ccaaa0104b2fe8b12bcd646e81f73b47535213e"
Brad Bishope42b3e32020-01-15 22:08:42 -050018
19BINCONFIG = "${bindir}/onig-config"
20
21inherit autotools binconfig-disabled ptest
22
23BBCLASSEXTEND = "native"
24
25do_compile_ptest() {
Patrick Williams8dd68482022-10-04 07:57:18 -050026 oe_runmake -C test buildtest-TESTS
Brad Bishope42b3e32020-01-15 22:08:42 -050027}
28
29do_install_ptest() {
Patrick Williams8dd68482022-10-04 07:57:18 -050030 mkdir -p ${D}${PTEST_PATH}/tests
31 install -m 0755 -t ${D}${PTEST_PATH}/tests/ ${B}/test/.libs/*
Brad Bishope42b3e32020-01-15 22:08:42 -050032}
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050033
34PROVIDES += "oniguruma"