blob: c92037d6e544d357a46b477f675f9b17bed3596f [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A xdg-desktop-portal backend for gnome."
2HOMEPAGE = "https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6DEPENDS = " \
7 glib-2.0-native \
8 gtk4\
9 xdg-desktop-portal \
10 xdg-desktop-portal-gtk \
11 libadwaita \
12 fontconfig \
13 gsettings-desktop-schemas \
14 gnome-desktop \
15 dconf \
16"
17
18RDEPENDS:${PN} = "xdg-desktop-portal xdg-desktop-portal-gtk"
19
20inherit meson pkgconfig gsettings features_check
21
22REQUIRED_DISTRO_FEATURES = "polkit"
23
24SRC_URI = "git://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome.git;protocol=https;nobranch=1"
25
26S = "${WORKDIR}/git"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050027SRCREV = "8e1c4fd928be500208ca1df62441a56e2569bfb8"
Andrew Geissler517393d2023-01-13 08:55:19 -060028
Patrick Williams8e7b46e2023-05-01 14:19:06 -050029PACKAGECONFIG ?= "screenshot screencast ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}"
Andrew Geissler517393d2023-01-13 08:55:19 -060030
Patrick Williams8e7b46e2023-05-01 14:19:06 -050031PACKAGECONFIG[wayland] = ",,wayland-native"
Andrew Geissler517393d2023-01-13 08:55:19 -060032PACKAGECONFIG[screenshot] = ",,,gnome-shell"
33PACKAGECONFIG[screencast] = ",,,mutter"
34
35FILES:${PN} += "${systemd_user_unitdir} ${datadir}"