blob: 5b0d61241ebe2ba7250ff51bfc6d3d6fad326b77 [file] [log] [blame]
Brad Bishop2d39a062019-10-28 08:33:36 -04001SUMMARY = "A multi-platform library for OpenGL, OpenGL ES, Vulkan, window and input"
2HOMEPAGE = "https://www.glfw.org/"
3DESCRIPTION = "GLFW is an Open Source, multi-platform library for OpenGL, \
4OpenGL ES and Vulkan application development. It provides a simple, \
5platform-independent API for creating windows, contexts and surfaces, reading \
6input, handling events, etc."
7LICENSE = "Zlib"
8LIC_FILES_CHKSUM = "file://LICENSE.md;md5=98d93d1ddc537f9b9ea6def64e046b5f"
9SECTION = "lib"
10
Brad Bishope42b3e32020-01-15 22:08:42 -050011inherit pkgconfig cmake features_check
12
13PV .= "+git${SRCPV}"
14SRCREV = "781fbbadb0bccc749058177b1385c82da9ace880"
Andrew Geissler595f6302022-01-24 19:11:47 +000015SRC_URI = "git://github.com/glfw/glfw.git;branch=master;protocol=https"
Brad Bishop2d39a062019-10-28 08:33:36 -040016
17S = "${WORKDIR}/git"
Brad Bishop2d39a062019-10-28 08:33:36 -040018
Brad Bishope42b3e32020-01-15 22:08:42 -050019EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON -DGLFW_BUILD_DOCS=OFF"
20
21CFLAGS += "-fPIC"
Brad Bishop2d39a062019-10-28 08:33:36 -040022
Patrick Williams8e7b46e2023-05-01 14:19:06 -050023DEPENDS = "libpng libglu zlib"
24REQUIRED_DISTRO_FEATURES = "opengl"
25ANY_OF_DISTRO_FEATURES = "wayland x11"
26
27# upstream considers x11 and wayland backends mutually exclusive and will
28# prioritize wayland if it is enabled, but wayland has dependencies that cannot
29# be satisfied by this layer so it is disabled by default
30
31PACKAGECONFIG ??= "x11"
32
33PACKAGECONFIG[wayland] = "-DGLFW_USE_WAYLAND=ON,,wayland wayland-native wayland-protocols extra-cmake-modules libxkbcommon"
34PACKAGECONFIG[x11] = ",,libxrandr libxinerama libxi libxcursor"
Brad Bishop2d39a062019-10-28 08:33:36 -040035
Patrick Williams213cb262021-08-07 19:21:33 -050036COMPATIBLE_HOST:libc-musl = "null"