blob: bbdc3b597089c0c89300d4bfcf6be1ace76aac35 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Cap'n Proto serialization/RPC system"
2DESCRIPTION = "Cap’n Proto is an insanely fast data interchange format and capability-based RPC system. "
3HOMEPAGE = "https://github.com/sandstorm-io/capnproto"
4SECTION = "console/tools"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://../LICENSE;md5=a05663ae6cca874123bf667a60dca8c9"
7
Patrick Williams8e7b46e2023-05-01 14:19:06 -05008SRC_URI = "git://github.com/sandstorm-io/capnproto.git;branch=release-0.10.4;protocol=https"
9SRCREV = "a91ec65323c2577732224d0cf6f5bf1e79d3a724"
Andrew Geissler517393d2023-01-13 08:55:19 -060010
11S = "${WORKDIR}/git/c++"
12
13inherit cmake
14
15CXXFLAGS:append:mips = " -latomic"
16CXXFLAGS:append:powerpc = " -latomic"
17CXXFLAGS:append:riscv32 = " -latomic"
18
19EXTRA_OECMAKE += "\
20 -DBUILD_TESTING=OFF \
21"
22
23FILES:${PN}-compiler = "${bindir}"
24
25PACKAGE_BEFORE_PN = "${PN}-compiler"
26RDEPENDS:${PN}-dev += "${PN}-compiler"
27
28BBCLASSEXTEND = "native nativesdk"