blob: be2935a385d95b20065fe1d884d02cb247f04741 [file] [log] [blame]
Brad Bishop2d39a062019-10-28 08:33:36 -04001SUMMARY = "Snowball compiler and stemming algorithms"
2HOMEPAGE = "https://snowballstem.org/"
3LICENSE = "BSD-3-Clause"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07004LIC_FILES_CHKSUM = "file://COPYING;md5=19139aaf3c8c8fa1ca6edd59c072fb9f"
Brad Bishop2d39a062019-10-28 08:33:36 -04005
Patrick Williams8e7b46e2023-05-01 14:19:06 -05006DEPENDS:append:class-target = " ${BPN}-native"
Brad Bishop2d39a062019-10-28 08:33:36 -04007
Patrick Williams8e7b46e2023-05-01 14:19:06 -05008SRC_URI = "git://github.com/snowballstem/snowball.git;branch=master;protocol=https \
9 file://0001-Build-so-lib.patch \
10 "
11SRCREV = "48a67a2831005f49c48ec29a5837640e23e54e6b"
Brad Bishop2d39a062019-10-28 08:33:36 -040012S = "${WORKDIR}/git"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050013
Brad Bishop2d39a062019-10-28 08:33:36 -040014LIBVER = "0.0.0"
15
16inherit lib_package
17
Patrick Williams213cb262021-08-07 19:21:33 -050018do_compile:prepend:class-target() {
Brad Bishop2d39a062019-10-28 08:33:36 -040019 # use native tools
20 sed -i 's:./snowball :snowball :g' ${S}/GNUmakefile
21}
22
23do_install() {
24 install -d ${D}${bindir}
25 install -m 755 ${S}/snowball ${D}${bindir}
26 install -m 755 ${S}/stemwords ${D}${bindir}
27
28 install -d ${D}${libdir}
29 install -m 755 ${S}/libstemmer.so.${LIBVER} ${D}${libdir}/
30 ln -s libstemmer.so.${LIBVER} ${D}${libdir}/libstemmer.so.0
31 ln -s libstemmer.so.${LIBVER} ${D}${libdir}/libstemmer.so
32
33 install -d ${D}${includedir}
Patrick Williams8e7b46e2023-05-01 14:19:06 -050034 install -m 644 ${S}/include/*.h ${D}${includedir}
Brad Bishop2d39a062019-10-28 08:33:36 -040035}
Patrick Williams8e7b46e2023-05-01 14:19:06 -050036
37BBCLASSEXTEND = "native"