blob: dd60d01db4d994725fba2b069401660e95fd154c [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Module::Build::Tiny - A tiny replacement for Module::Build"
2DESCRIPTION = "Many Perl distributions use a Build.PL file instead of a \
3Makefile.PL file to drive distribution configuration, build, test and \
4installation. Traditionally, Build.PL uses Module::Build as the underlying \
5build system. This module provides a simple, lightweight, drop-in replacement. \
6Whereas Module::Build has over 6,700 lines of code; this module has less than \
7120, yet supports the features needed by most distributions."
8SECTION = "libs"
9
10HOMEPAGE = "http://search.cpan.org/~leont/Module-Build-Tiny/"
11
Andrew Geissler9aee5002022-03-30 16:27:02 +000012LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050013LIC_FILES_CHKSUM = "file://LICENSE;md5=6374136f6774db2f51cc116f5efbf705"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050014
15DEPENDS = "libextutils-config-perl-native libextutils-helpers-perl-native libextutils-installpaths-perl-native"
16
17SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/Module-Build-Tiny-${PV}.tar.gz"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050018SRC_URI[sha256sum] = "68f4e4620e8a75124ce2dadee48d2ba5160b9167012924588d6fb242ff2d7206"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019
20S = "${WORKDIR}/Module-Build-Tiny-${PV}"
21
22inherit cpan_build
23
24do_install () {
25 cpan_build_do_install
26}
27
Patrick Williams213cb262021-08-07 19:21:33 -050028RDEPENDS:${PN} = " libextutils-config-perl \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050029 libextutils-helpers-perl \
30 libextutils-installpaths-perl \
31 perl-module-xsloader \
32 perl-module-file-spec \
33 perl-module-io-handle \
34 perl-module-tap-harness-env \
35 perl-module-ipc-open3 \
36 perl-module-file-path \
37 perl-module-cpan \
38 perl-module-extutils-cbuilder \
39 perl-module-getopt-long \
40 perl-module-extutils-makemaker \
41 perl-module-exporter \
42 perl-module-carp \
43 perl-module-test-more \
44 perl-module-text-parsewords \
45 perl-module-load \
46 perl-module-file-temp \
47 perl-module-data-dumper \
48 perl-module-extutils-parsexs \
49 perl-module-pod-man \
50 perl-module-json-pp \
51"
52
53BBCLASSEXTEND = "native"