blob: 9b8ea94c2aff4c35aa3a5866eee9d95871bbb12e [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A simple wrapper around optparse for powerful command line utilities."
2DESCRIPTION = "\
3Click is a Python package for creating beautiful command line interfaces \
4in a composable way with as little code as necessary. It's the "Command \
5Line Interface Creation Kit". It's highly configurable but comes with \
6sensible defaults out of the box."
7HOMEPAGE = "http://click.pocoo.org/"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=1fa98232fd645608937a0fdc82e999b8"
10
Andrew Geisslerd5838332022-05-27 11:33:10 -050011SRC_URI[sha256sum] = "7682dc8afb30297001674575ea00d1814d808d6a36af415a82bd481d37ba7b8e"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000012
13inherit pypi setuptools3 ptest
14
15SRC_URI += " \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050016 file://0001-tests-Fix-test_bytes_args.patch \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000017 file://run-ptest \
18"
19
20RDEPENDS:${PN}-ptest += " \
21 ${PYTHON_PN}-pytest \
22 ${PYTHON_PN}-terminal \
23 ${PYTHON_PN}-unixadmin \
24"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29 cp -rf ${S}/setup.cfg ${D}${PTEST_PATH}/
30 cp -rf ${S}/docs ${D}${PTEST_PATH}/
31}
32
33UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/"
34
35CLEANBROKEN = "1"
36
37RDEPENDS:${PN} += "\
38 ${PYTHON_PN}-io \
39 ${PYTHON_PN}-threading \
40 "
41
42BBCLASSEXTEND = "native nativesdk"