blob: 129c3147cff03aed5c59c36b72d7c194de360a91 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "pandas library for high-performance data analysis tools"
2DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
3high-performance, easy-to-use data structures and data analysis tools for \
4the Python programming language."
5HOMEPAGE = "http://pandas.pydata.org/"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=c1cc9ab35a8b2aabf933cd6d245b5db3"
8
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06009SRC_URI[sha256sum] = "74a3fd7e5a7ec052f183273dc7b0acd3a863edf7520f5d3a1765c04ffdb3b0b1"
Andrew Geissler517393d2023-01-13 08:55:19 -060010
11inherit pypi setuptools3
12
13DEPENDS += " \
14 ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
15"
16
Patrick Williams8e7b46e2023-05-01 14:19:06 -050017PACKAGESPLITFUNCS =+ "fix_cythonized_sources"
18
19fix_cythonized_sources() {
20 for f in `grep -l -r -e '\/* Generated by Cython.*/$' ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}`; do
21 if [ -e $f ]; then
22 sed -i -e 's#${RECIPE_SYSROOT_NATIVE}##g' $f
23 fi
24 done
25}
26
Andrew Geissler517393d2023-01-13 08:55:19 -060027CFLAGS:append:toolchain-clang = " -Wno-error=deprecated-declarations"
28
29RDEPENDS:${PN} += " \
30 ${PYTHON_PN}-json \
31 ${PYTHON_PN}-numpy \
32 ${PYTHON_PN}-dateutil \
33 ${PYTHON_PN}-dateutil-zoneinfo \
34 ${PYTHON_PN}-pytz \
35 ${PYTHON_PN}-profile \
36"