blob: f67090da74f9493c17860948077c7be248549fa9 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Python interface to PROJ (cartographic projections and coordinate transformations library)"
2LICENSE = "MIT"
Patrick Williams8e7b46e2023-05-01 14:19:06 -05003LIC_FILES_CHKSUM = "file://LICENSE;md5=873757af01d2d221eedb422c4c1dd163"
Andrew Geissler517393d2023-01-13 08:55:19 -06004DEPENDS = "python3-cython proj"
5DEPENDS:append:class-target = " python3-cython-native proj-native"
6
7PYPI_PACKAGE = "pyproj"
8
9inherit pypi setuptools3
10
Patrick Williams8e7b46e2023-05-01 14:19:06 -050011SRC_URI[sha256sum] = "9859d1591c1863414d875ae0759e72c2cffc01ab989dc64137fbac572cc81bf6"
Andrew Geissler517393d2023-01-13 08:55:19 -060012
13RDEPENDS:${PN} = "${PYTHON_PN}-certifi proj"
14
15export PROJ_INCDIR = "${STAGING_INCDIR}"
16export PROJ_LIBDIR = "${STAGING_LIBDIR}"
17export PROJ_DIR = "${STAGING_BINDIR_NATIVE}/.."