blob: 1661e71239d37d907faf5356845f2df8d6b89afe [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Run-time type checker for Python"
2HOMEPAGE = "https://pypi.org/project/typeguard/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
5
Patrick Williams8e7b46e2023-05-01 14:19:06 -05006SRC_URI[sha256sum] = "fee5297fdb28f8e9efcb8142b5ee219e02375509cd77ea9d270b5af826358d5a"
Andrew Geissler595f6302022-01-24 19:11:47 +00007
Andrew Geissler9aee5002022-03-30 16:27:02 +00008inherit pypi python_setuptools_build_meta ptest
Andrew Geissler595f6302022-01-24 19:11:47 +00009
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15 ${PYTHON_PN}-pytest \
16 ${PYTHON_PN}-typing-extensions \
17 ${PYTHON_PN}-unixadmin \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
24
25DEPENDS += "\
26 python3-distutils-extra-native \
27 python3-setuptools-scm-native \
28"
29
30BBCLASSEXTEND = "native nativesdk"