blob: d556e8b6d00c4bef79f005e79d317c9afc0914a2 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Python 2 and 3 compatibility library"
2HOMEPAGE = "https://xlsxwriter.readthedocs.io"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=12d9fac1f0049be71ab5aa4a78da02b0"
6
7inherit pypi setuptools3
8
9PYPI_PACKAGE = "XlsxWriter"
10
11RDEPENDS:${PN} += " \
12 python3-crypt \
13 python3-datetime \
14 python3-compression \
15 python3-numbers \
16 python3-io \
17"
18
Patrick Williams8e7b46e2023-05-01 14:19:06 -050019SRC_URI[sha256sum] = "02913b50b74c00f165933d5da3e3a02cab4204cb4932722a1b342c5c71034122"
Andrew Geissler517393d2023-01-13 08:55:19 -060020
21BBCLASSEXTEND = "native nativesdk"