blob: d1c1fa095fc86793b108a752e6b0d1a5407684f6 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7DEPENDS:append:class-target = " ${PYTHON_PN}-native ${PYTHON_PN}"
8DEPENDS:append:class-nativesdk = " ${PYTHON_PN}-native ${PYTHON_PN}"
9RDEPENDS:${PN}:append:class-target = " ${PYTHON_PN}-core"
10
11export STAGING_INCDIR
12export STAGING_LIBDIR
13
14# LDSHARED is the ld *command* used to create shared library
15export LDSHARED = "${CCLD} -shared"
16# LDXXSHARED is the ld *command* used to create shared library of C++
17# objects
18export LDCXXSHARED = "${CXX} -shared"
19# CCSHARED are the C *flags* used to create objects to go into a shared
20# library (module)
21export CCSHARED = "-fPIC -DPIC"
22# LINKFORSHARED are the flags passed to the $(CC) command that links
23# the python executable
24export LINKFORSHARED = "${SECURITY_CFLAGS} -Xlinker -export-dynamic"
25
Patrick Williams8e7b46e2023-05-01 14:19:06 -050026FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}"
27FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
28FILES:${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/*.la"
Patrick Williams92b42cb2022-09-03 06:53:57 -050029
Patrick Williams92b42cb2022-09-03 06:53:57 -050030inherit python3native python3targetconfig