blob: 6cad0dd7c63fb85f0881444409f5f08217da0bb2 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "a fast C/C++ compiler cache"
2DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
3by caching the result of previous compilations and detecting when the \
4same compilation is being done again. Supported languages are C, C\+\+, \
5Objective-C and Objective-C++."
6HOMEPAGE = "http://ccache.samba.org"
7SECTION = "devel"
8
9LICENSE = "GPL-3.0-or-later"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050010LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=43a02b74c9eb73a0b978ae5082f5f1b6"
Andrew Geissler517393d2023-01-13 08:55:19 -060011
12DEPENDS = "zstd"
13
14SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${BP}.tar.gz \
15 file://0001-xxhash.h-Fix-build-with-gcc-12.patch \
16 "
Patrick Williams8e7b46e2023-05-01 14:19:06 -050017SRC_URI[sha256sum] = "ac4b01748fd59cfe07e070c34432b91bdd0fd8640e1e653a80b01d6a523186b0"
Andrew Geissler517393d2023-01-13 08:55:19 -060018
19inherit cmake github-releases
20
21PATCHTOOL = "patch"
22
23BBCLASSEXTEND = "native nativesdk"
24
25PACKAGECONFIG[docs] = "-DENABLE_DOCUMENTATION=ON,-DENABLE_DOCUMENTATION=OFF,asciidoc"
26PACKAGECONFIG[redis] = "-DREDIS_STORAGE_BACKEND=ON,-DREDIS_STORAGE_BACKEND=OFF,hiredis"