blob: 21f2eb6ba4602e2dc3d4114df72c8a9e56b89700 [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "Modern password hashing for your software and your servers."
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
4HOMEPAGE = "https://pypi.org/project/bcrypt/"
5
6DEPENDS += "${PYTHON_PN}-cffi-native"
7
Patrick Williams2390b1b2022-11-03 13:47:49 -05008SRC_URI[sha256sum] = "27d375903ac8261cfe4047f6709d16f7d18d39b1ec92aaf72af989552a650ebd"
Andrew Geissler9aee5002022-03-30 16:27:02 +00009
Patrick Williams2390b1b2022-11-03 13:47:49 -050010inherit pypi python_setuptools3_rust ptest cargo-update-recipe-crates
Andrew Geissler9aee5002022-03-30 16:27:02 +000011
12SRC_URI += " \
13 file://run-ptest \
14"
15
Patrick Williams2390b1b2022-11-03 13:47:49 -050016require ${BPN}-crates.inc
17
Andrew Geissler9aee5002022-03-30 16:27:02 +000018RDEPENDS:${PN}-ptest += " \
19 ${PYTHON_PN}-pytest \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050020 ${PYTHON_PN}-unittest-automake-output \
Andrew Geissler9aee5002022-03-30 16:27:02 +000021"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
27
28RDEPENDS:${PN}:class-target += "\
29 ${PYTHON_PN}-cffi \
30 ${PYTHON_PN}-ctypes \
31 ${PYTHON_PN}-shell \
32 ${PYTHON_PN}-six \
33"