blob: 36c6233b331257958dd818b720fc63c9e0cf58f4 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "https://www.webkitgtk.org/"
3BUGTRACKER = "https://bugs.webkit.org/"
4
5LICENSE = "BSD-2-Clause & LGPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
9 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
10 "
11
12SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
13 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
14 file://reproducibility.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060015 file://0d3344e17d258106617b0e6d783d073b188a2548.patch \
Patrick Williamsb9af8752023-01-30 13:28:01 -060016 file://d318bb461f040b90453bc4e100dcf967243ecd98.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060017 "
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060018SRC_URI[sha256sum] = "40c20c43022274df5893f22b1054fa894c3eea057389bb08aee08c5b0bb0c1a7"
Andrew Geissler517393d2023-01-13 08:55:19 -060019
20inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gi-docgen
21
22ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
23REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'opengl', '', d)}"
24
25CVE_PRODUCT = "webkitgtk webkitgtk\+"
26
Andrew Geisslerc5535c92023-01-27 16:10:19 -060027DEPENDS += " \
Andrew Geissler517393d2023-01-13 08:55:19 -060028 ruby-native \
29 gperf-native \
30 cairo \
31 harfbuzz \
32 jpeg \
33 atk \
34 libwebp \
35 gtk+3 \
36 libxslt \
37 libtasn1 \
38 libnotify \
39 gstreamer1.0 \
40 gstreamer1.0-plugins-base \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050041 glib-2.0-native \
42 gettext-native \
Andrew Geissler517393d2023-01-13 08:55:19 -060043 "
44
45PACKAGECONFIG_SOUP ?= "soup3"
46PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \
47 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '', d)} \
48 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'webgl gles2', d)} \
49 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl-or-es', '', d)} \
50 enchant \
51 libsecret \
52 ${PACKAGECONFIG_SOUP} \
53 "
54
55PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland libwpe wpebackend-fdo wayland-native"
56PACKAGECONFIG[angle] = "-DUSE_ANGLE_WEBGL=ON,-DUSE_ANGLE_WEBGL=OFF"
57PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11 libxcomposite libxdamage libxrender libxt"
58PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
59PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant2"
60PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
61PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/egl"
62PACKAGECONFIG[opengl] = "-DENABLE_GRAPHICS_CONTEXT_GL=ON,-DENABLE_GRAPHICS_CONTEXT_GL=OFF,virtual/egl"
63PACKAGECONFIG[opengl-or-es] = "-DUSE_OPENGL_OR_ES=ON,-DUSE_OPENGL_OR_ES=OFF"
64PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret"
65PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
66PACKAGECONFIG[woff2] = "-DUSE_WOFF2=ON,-DUSE_WOFF2=OFF,woff2"
67PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg"
68PACKAGECONFIG[systemd] = "-DUSE_SYSTEMD=ON,-DUSE_SYSTEMD=off,systemd"
69PACKAGECONFIG[reduce-size] = "-DCMAKE_BUILD_TYPE=MinSizeRel,-DCMAKE_BUILD_TYPE=Release,,"
70PACKAGECONFIG[lcms] = "-DUSE_LCMS=ON,-DUSE_LCMS=OFF,lcms"
71PACKAGECONFIG[soup2] = "-DUSE_SOUP2=ON,-DUSE_SOUP2=OFF,libsoup-2.4,,,soup3"
72PACKAGECONFIG[soup3] = ",,libsoup,,,soup2"
73PACKAGECONFIG[journald] = "-DENABLE_JOURNALD_LOG=ON,-DENABLE_JOURNALD_LOG=OFF,systemd"
74
Andrew Geissler517393d2023-01-13 08:55:19 -060075EXTRA_OECMAKE = " \
76 -DPORT=GTK \
77 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
78 ${@bb.utils.contains('GIDOCGEN_ENABLED', 'True', '-DENABLE_DOCUMENTATION=ON', '-DENABLE_DOCUMENTATION=OFF', d)} \
79 -DENABLE_MINIBROWSER=ON \
Andrew Geissler517393d2023-01-13 08:55:19 -060080 -DENABLE_BUBBLEWRAP_SANDBOX=OFF \
81 -DENABLE_GAMEPAD=OFF \
82 "
83
84# Javascript JIT is not supported on ARC
85EXTRA_OECMAKE:append:arc = " -DENABLE_JIT=OFF "
86# By default 25-bit "medium" calls are used on ARC
87# which is not enough for binaries larger than 32 MiB
88CFLAGS:append:arc = " -mlong-calls"
89CXXFLAGS:append:arc = " -mlong-calls"
90
91# Needed for non-mesa graphics stacks when x11 is disabled
92CXXFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '-DEGL_NO_X11=1', d)}"
93
94# Javascript JIT is not supported on powerpc
95EXTRA_OECMAKE:append:powerpc = " -DENABLE_JIT=OFF "
96EXTRA_OECMAKE:append:powerpc64 = " -DENABLE_JIT=OFF "
97
98# ARM JIT code does not build on ARMv4/5/6 anymore
99EXTRA_OECMAKE:append:armv5 = " -DENABLE_JIT=OFF "
100EXTRA_OECMAKE:append:armv6 = " -DENABLE_JIT=OFF "
101EXTRA_OECMAKE:append:armv4 = " -DENABLE_JIT=OFF "
102
103EXTRA_OECMAKE:append:mipsarch = " -DUSE_LD_GOLD=OFF "
104EXTRA_OECMAKE:append:powerpc = " -DUSE_LD_GOLD=OFF "
105
106# JIT and gold linker does not work on RISCV
107EXTRA_OECMAKE:append:riscv32 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
108EXTRA_OECMAKE:append:riscv64 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
109
110# JIT not supported on MIPS either
111EXTRA_OECMAKE:append:mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
112
113# JIT not supported on X32
114# An attempt was made to upstream JIT support for x32 in
115# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
116# unresolved due to limited X32 adoption.
117EXTRA_OECMAKE:append:x86-x32 = " -DENABLE_JIT=OFF "
118
119SECURITY_CFLAGS:remove:aarch64 = "-fpie"
120SECURITY_CFLAGS:append:aarch64 = " -fPIE"
121
122FILES:${PN} += "${libdir}/webkit2gtk-4.*/injected-bundle/libwebkit2gtkinjectedbundle.so"
123
124RRECOMMENDS:${PN} += "ca-certificates shared-mime-info"
125
126# http://errors.yoctoproject.org/Errors/Details/20370/
127ARM_INSTRUCTION_SET:armv4 = "arm"
128ARM_INSTRUCTION_SET:armv5 = "arm"
129ARM_INSTRUCTION_SET:armv6 = "arm"
130
131# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
132# https://bugs.webkit.org/show_bug.cgi?id=159880
133# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
134# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
135ARM_INSTRUCTION_SET:armv7a = "thumb"
136ARM_INSTRUCTION_SET:armv7r = "thumb"
137ARM_INSTRUCTION_SET:armv7ve = "thumb"
138
139# introspection inside qemu-arm hangs forever on musl/arm builds
140# therefore disable GI_DATA
141GI_DATA_ENABLED:libc-musl:armv7a = "False"
142GI_DATA_ENABLED:libc-musl:armv7ve = "False"
143
144# Can't be built with ccache
145CCACHE_DISABLE = "1"
146
147PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess"
148src_package_preprocess () {
149 # Trim build paths from comments in generated sources to ensure reproducibility
150 sed -i -e "s,${WORKDIR},,g" \
151 ${B}/JavaScriptCore/DerivedSources/*.h \
152 ${B}/JavaScriptCore/DerivedSources/yarr/*.h \
153 ${B}/JavaScriptCore/PrivateHeaders/JavaScriptCore/*.h \
154 ${B}/WebKit2Gtk/DerivedSources/webkit2/*.cpp \
155 ${B}/WebKit2Gtk/DerivedSources/webkit2/*.h
156
157}
158