blob: 01e5b35d0ee259c701369d72abbcaa8225e6d13f [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Mesa demo applications"
2DESCRIPTION = "This package includes the demonstration application, such as glxgears. \
3These applications can be used for Mesa validation and benchmarking."
4HOMEPAGE = "http://mesa3d.org"
5BUGTRACKER = "https://bugs.freedesktop.org"
6SECTION = "x11"
7
8LICENSE = "MIT & PD"
9LIC_FILES_CHKSUM = "file://src/xdemos/glxgears.c;beginline=1;endline=20;md5=914225785450eff644a86c871d3ae00e \
10 file://src/xdemos/glxdemo.c;beginline=1;endline=8;md5=b01d5ab1aee94d35b7efaa2ef48e1a06"
11
Brad Bishop15ae2502019-06-18 21:44:24 -040012SRC_URI = "https://mesa.freedesktop.org/archive/demos/${BPN}-${PV}.tar.bz2 \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060013 file://0001-mesa-demos-Add-missing-data-files.patch \
14 file://0003-configure-Allow-to-disable-demos-which-require-GLEW-.patch \
15 file://0004-Use-DEMOS_DATA_DIR-to-locate-data-files.patch \
16 file://0007-Install-few-more-test-programs.patch \
17 file://0008-glsl-perf-Add-few-missing-.glsl-.vert-.frag-files-to.patch \
18 file://0009-glsl-perf-Install-.glsl-.vert-.frag-files.patch \
19 file://0012-mesa-demos-OpenVG-demos-with-single-frame-need-eglSw.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060020 "
Brad Bishop15ae2502019-06-18 21:44:24 -040021SRC_URI[md5sum] = "6b65a02622765522176d00f553086fa3"
22SRC_URI[sha256sum] = "01e99c94a0184e63e796728af89bfac559795fb2a0d6f506fa900455ca5fff7d"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060023
Brad Bishop6dbb3162019-11-25 09:41:34 -050024inherit autotools pkgconfig features_check
Patrick Williamsc0f7c042017-02-23 20:41:17 -060025# depends on virtual/egl, virtual/libgl ...
26REQUIRED_DISTRO_FEATURES = "opengl x11"
27
28PACKAGECONFIG ?= "drm osmesa freetype2 gbm egl gles1 gles2 \
Andrew Geissler595f6302022-01-24 19:11:47 +000029 x11 glew glu"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060030
31# The Wayland code doesn't work with Wayland 1.0, so disable it for now
Brad Bishop6e60e8b2018-02-01 10:27:11 -050032#${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060033
34EXTRA_OECONF = "--with-system-data-files"
35
36PACKAGECONFIG[drm] = "--enable-libdrm,--disable-libdrm,libdrm"
37PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
38PACKAGECONFIG[freetype2] = "--enable-freetype2,--disable-freetype2,freetype"
39PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgl"
40PACKAGECONFIG[gles1] = "--enable-gles1,--disable-gles1,virtual/libgles1"
41PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050042PACKAGECONFIG[glut] = "--with-glut=${STAGING_EXECPREFIXDIR},--without-glut,freeglut"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060043PACKAGECONFIG[osmesa] = "--enable-osmesa,--disable-osmesa,"
44PACKAGECONFIG[vg] = "--enable-vg,--disable-vg,virtual/libopenvg"
45PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,virtual/libgl wayland"
46PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11"
47PACKAGECONFIG[glew] = "--enable-glew,--disable-glew,glew"
48PACKAGECONFIG[glu] = "--enable-glu,--disable-glu,virtual/libgl"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060049
Patrick Williams213cb262021-08-07 19:21:33 -050050do_install:append() {
Patrick Williamsc0f7c042017-02-23 20:41:17 -060051 # it can be completely empty when all PACKAGECONFIG options are disabled
52 rmdir --ignore-fail-on-non-empty ${D}${bindir}
53
54 if [ -f ${D}${bindir}/clear ]; then
55 mv ${D}${bindir}/clear ${D}${bindir}/clear.mesa-demos
56 fi
57}