blob: bcea0b3cb53e4c6df733992578ac80d2b59d78a2 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Populates LICENSE_DIRECTORY as set in distro config with the license files as set by
2# LIC_FILES_CHKSUM.
3# TODO:
4# - There is a real issue revolving around license naming standards.
5
6LICENSE_DIRECTORY ??= "${DEPLOY_DIR}/licenses"
7LICSSTATEDIR = "${WORKDIR}/license-destdir/"
8
9# Create extra package with license texts and add it to RRECOMMENDS_${PN}
10LICENSE_CREATE_PACKAGE[type] = "boolean"
11LICENSE_CREATE_PACKAGE ??= "0"
12LICENSE_PACKAGE_SUFFIX ??= "-lic"
13LICENSE_FILES_DIRECTORY ??= "${datadir}/licenses/"
14
15addtask populate_lic after do_patch before do_build
16do_populate_lic[dirs] = "${LICSSTATEDIR}/${PN}"
17do_populate_lic[cleandirs] = "${LICSSTATEDIR}"
18
Patrick Williamsc124f4f2015-09-15 14:41:29 -050019python do_populate_lic() {
20 """
21 Populate LICENSE_DIRECTORY with licenses.
22 """
23 lic_files_paths = find_license_files(d)
24
25 # The base directory we wrangle licenses to
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026 destdir = os.path.join(d.getVar('LICSSTATEDIR'), d.getVar('PN'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027 copy_license_files(lic_files_paths, destdir)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050028 info = get_recipe_info(d)
29 with open(os.path.join(destdir, "recipeinfo"), "w") as f:
30 for key in sorted(info.keys()):
31 f.write("%s: %s\n" % (key, info[key]))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050032}
33
Andrew Geisslerd1e89492021-02-12 15:35:20 -060034PSEUDO_IGNORE_PATHS .= ",${@','.join(((d.getVar('COMMON_LICENSE_DIR') or '') + ' ' + (d.getVar('LICENSE_PATH') or '')).split())}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050035# it would be better to copy them in do_install_append, but find_license_filesa is python
36python perform_packagecopy_prepend () {
37 enabled = oe.data.typed_value('LICENSE_CREATE_PACKAGE', d)
Brad Bishop6e60e8b2018-02-01 10:27:11 -050038 if d.getVar('CLASSOVERRIDE') == 'class-target' and enabled:
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039 lic_files_paths = find_license_files(d)
40
41 # LICENSE_FILES_DIRECTORY starts with '/' so os.path.join cannot be used to join D and LICENSE_FILES_DIRECTORY
Brad Bishop6e60e8b2018-02-01 10:27:11 -050042 destdir = d.getVar('D') + os.path.join(d.getVar('LICENSE_FILES_DIRECTORY'), d.getVar('PN'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050043 copy_license_files(lic_files_paths, destdir)
44 add_package_and_files(d)
45}
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050046perform_packagecopy[vardeps] += "LICENSE_CREATE_PACKAGE"
47
48def get_recipe_info(d):
49 info = {}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050050 info["PV"] = d.getVar("PV")
51 info["PR"] = d.getVar("PR")
52 info["LICENSE"] = d.getVar("LICENSE")
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050053 return info
Patrick Williamsc124f4f2015-09-15 14:41:29 -050054
55def add_package_and_files(d):
Brad Bishop6e60e8b2018-02-01 10:27:11 -050056 packages = d.getVar('PACKAGES')
57 files = d.getVar('LICENSE_FILES_DIRECTORY')
58 pn = d.getVar('PN')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050059 pn_lic = "%s%s" % (pn, d.getVar('LICENSE_PACKAGE_SUFFIX', False))
Brad Bishop316dfdd2018-06-25 12:45:53 -040060 if pn_lic in packages.split():
Patrick Williamsc124f4f2015-09-15 14:41:29 -050061 bb.warn("%s package already existed in %s." % (pn_lic, pn))
62 else:
63 # first in PACKAGES to be sure that nothing else gets LICENSE_FILES_DIRECTORY
64 d.setVar('PACKAGES', "%s %s" % (pn_lic, packages))
65 d.setVar('FILES_' + pn_lic, files)
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080066 for pn in packages.split():
67 if pn == pn_lic:
68 continue
Brad Bishop6e60e8b2018-02-01 10:27:11 -050069 rrecommends_pn = d.getVar('RRECOMMENDS_' + pn)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050070 if rrecommends_pn:
71 d.setVar('RRECOMMENDS_' + pn, "%s %s" % (pn_lic, rrecommends_pn))
72 else:
73 d.setVar('RRECOMMENDS_' + pn, "%s" % (pn_lic))
74
75def copy_license_files(lic_files_paths, destdir):
76 import shutil
Patrick Williamsc0f7c042017-02-23 20:41:17 -060077 import errno
Patrick Williamsc124f4f2015-09-15 14:41:29 -050078
79 bb.utils.mkdirhier(destdir)
Brad Bishop6e60e8b2018-02-01 10:27:11 -050080 for (basename, path, beginline, endline) in lic_files_paths:
Patrick Williamsc124f4f2015-09-15 14:41:29 -050081 try:
82 src = path
83 dst = os.path.join(destdir, basename)
84 if os.path.exists(dst):
85 os.remove(dst)
Brad Bishop37a0e4d2017-12-04 01:01:44 -050086 if os.path.islink(src):
87 src = os.path.realpath(src)
Brad Bishop6e60e8b2018-02-01 10:27:11 -050088 canlink = os.access(src, os.W_OK) and (os.stat(src).st_dev == os.stat(destdir).st_dev) and beginline is None and endline is None
Patrick Williamsc0f7c042017-02-23 20:41:17 -060089 if canlink:
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050090 try:
Patrick Williamsc0f7c042017-02-23 20:41:17 -060091 os.link(src, dst)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050092 except OSError as err:
Patrick Williamsc0f7c042017-02-23 20:41:17 -060093 if err.errno == errno.EXDEV:
94 # Copy license files if hard-link is not possible even if st_dev is the
95 # same on source and destination (docker container with device-mapper?)
96 canlink = False
97 else:
98 raise
Brad Bishop6e60e8b2018-02-01 10:27:11 -050099 # Only chown if we did hardling, and, we're running under pseudo
100 if canlink and os.environ.get('PSEUDO_DISABLED') == '0':
101 os.chown(dst,0,0)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600102 if not canlink:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500103 begin_idx = int(beginline)-1 if beginline is not None else None
104 end_idx = int(endline) if endline is not None else None
105 if begin_idx is None and end_idx is None:
106 shutil.copyfile(src, dst)
107 else:
108 with open(src, 'rb') as src_f:
109 with open(dst, 'wb') as dst_f:
110 dst_f.write(b''.join(src_f.readlines()[begin_idx:end_idx]))
111
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500112 except Exception as e:
113 bb.warn("Could not copy license file %s to %s: %s" % (src, dst, e))
114
115def find_license_files(d):
116 """
117 Creates list of files used in LIC_FILES_CHKSUM and generic LICENSE files.
118 """
119 import shutil
120 import oe.license
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600121 from collections import defaultdict, OrderedDict
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500122
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500123 # All the license files for the package
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500124 lic_files = d.getVar('LIC_FILES_CHKSUM') or ""
125 pn = d.getVar('PN')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500126 # The license files are located in S/LIC_FILE_CHECKSUM.
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500127 srcdir = d.getVar('S')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500128 # Directory we store the generic licenses as set in the distro configuration
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500129 generic_directory = d.getVar('COMMON_LICENSE_DIR')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500130 # List of basename, path tuples
131 lic_files_paths = []
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500132 # hash for keep track generic lics mappings
133 non_generic_lics = {}
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600134 # Entries from LIC_FILES_CHKSUM
135 lic_chksums = {}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500136 license_source_dirs = []
137 license_source_dirs.append(generic_directory)
138 try:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500139 additional_lic_dirs = d.getVar('LICENSE_PATH').split()
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500140 for lic_dir in additional_lic_dirs:
141 license_source_dirs.append(lic_dir)
142 except:
143 pass
144
145 class FindVisitor(oe.license.LicenseVisitor):
146 def visit_Str(self, node):
147 #
148 # Until I figure out what to do with
149 # the two modifiers I support (or greater = +
150 # and "with exceptions" being *
151 # we'll just strip out the modifier and put
152 # the base license.
153 find_license(node.s.replace("+", "").replace("*", ""))
154 self.generic_visit(node)
155
156 def find_license(license_type):
157 try:
158 bb.utils.mkdirhier(gen_lic_dest)
159 except:
160 pass
161 spdx_generic = None
162 license_source = None
163 # If the generic does not exist we need to check to see if there is an SPDX mapping to it,
164 # unless NO_GENERIC_LICENSE is set.
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500165 for lic_dir in license_source_dirs:
166 if not os.path.isfile(os.path.join(lic_dir, license_type)):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500167 if d.getVarFlag('SPDXLICENSEMAP', license_type) != None:
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500168 # Great, there is an SPDXLICENSEMAP. We can copy!
169 bb.debug(1, "We need to use a SPDXLICENSEMAP for %s" % (license_type))
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500170 spdx_generic = d.getVarFlag('SPDXLICENSEMAP', license_type)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500171 license_source = lic_dir
172 break
173 elif os.path.isfile(os.path.join(lic_dir, license_type)):
174 spdx_generic = license_type
175 license_source = lic_dir
176 break
177
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500178 non_generic_lic = d.getVarFlag('NO_GENERIC_LICENSE', license_type)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500179 if spdx_generic and license_source:
180 # we really should copy to generic_ + spdx_generic, however, that ends up messing the manifest
181 # audit up. This should be fixed in emit_pkgdata (or, we actually got and fix all the recipes)
182
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500183 lic_files_paths.append(("generic_" + license_type, os.path.join(license_source, spdx_generic),
184 None, None))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500185
186 # The user may attempt to use NO_GENERIC_LICENSE for a generic license which doesn't make sense
187 # and should not be allowed, warn the user in this case.
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500188 if d.getVarFlag('NO_GENERIC_LICENSE', license_type):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500189 bb.warn("%s: %s is a generic license, please don't use NO_GENERIC_LICENSE for it." % (pn, license_type))
190
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600191 elif non_generic_lic and non_generic_lic in lic_chksums:
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500192 # if NO_GENERIC_LICENSE is set, we copy the license files from the fetched source
193 # of the package rather than the license_source_dirs.
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600194 lic_files_paths.append(("generic_" + license_type,
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500195 os.path.join(srcdir, non_generic_lic), None, None))
196 non_generic_lics[non_generic_lic] = license_type
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500197 else:
198 # Add explicity avoid of CLOSED license because this isn't generic
199 if license_type != 'CLOSED':
200 # And here is where we warn people that their licenses are lousy
201 bb.warn("%s: No generic license file exists for: %s in any provider" % (pn, license_type))
202 pass
203
204 if not generic_directory:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600205 bb.fatal("COMMON_LICENSE_DIR is unset. Please set this in your distro config")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500206
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500207 for url in lic_files.split():
208 try:
Brad Bishop220d5532018-08-14 00:59:39 +0100209 (method, host, path, user, pswd, parm) = bb.fetch.decodeurl(url)
210 if method != "file" or not path:
211 raise bb.fetch.MalformedUrl()
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500212 except bb.fetch.MalformedUrl:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500213 bb.fatal("%s: LIC_FILES_CHKSUM contains an invalid URL: %s" % (d.getVar('PF'), url))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500214 # We want the license filename and path
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500215 chksum = parm.get('md5', None)
216 beginline = parm.get('beginline')
217 endline = parm.get('endline')
218 lic_chksums[path] = (chksum, beginline, endline)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500219
220 v = FindVisitor()
221 try:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500222 v.visit_string(d.getVar('LICENSE'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500223 except oe.license.InvalidLicense as exc:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500224 bb.fatal('%s: %s' % (d.getVar('PF'), exc))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500225 except SyntaxError:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500226 bb.warn("%s: Failed to parse it's LICENSE field." % (d.getVar('PF')))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600227 # Add files from LIC_FILES_CHKSUM to list of license files
228 lic_chksum_paths = defaultdict(OrderedDict)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500229 for path, data in sorted(lic_chksums.items()):
230 lic_chksum_paths[os.path.basename(path)][data] = (os.path.join(srcdir, path), data[1], data[2])
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600231 for basename, files in lic_chksum_paths.items():
232 if len(files) == 1:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500233 # Don't copy again a LICENSE already handled as non-generic
234 if basename in non_generic_lics:
235 continue
236 data = list(files.values())[0]
237 lic_files_paths.append(tuple([basename] + list(data)))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600238 else:
239 # If there are multiple different license files with identical
240 # basenames we rename them to <file>.0, <file>.1, ...
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500241 for i, data in enumerate(files.values()):
242 lic_files_paths.append(tuple(["%s.%d" % (basename, i)] + list(data)))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600243
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500244 return lic_files_paths
245
246def return_spdx(d, license):
247 """
248 This function returns the spdx mapping of a license if it exists.
249 """
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500250 return d.getVarFlag('SPDXLICENSEMAP', license)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500251
252def canonical_license(d, license):
253 """
254 Return the canonical (SPDX) form of the license if available (so GPLv3
Andrew Geissler90fd73c2021-03-05 15:25:55 -0600255 becomes GPL-3.0) or the passed license if there is no canonical form.
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500256 """
Andrew Geissler90fd73c2021-03-05 15:25:55 -0600257 return d.getVarFlag('SPDXLICENSEMAP', license) or license
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500258
Andrew Geissler82c905d2020-04-13 13:39:40 -0500259def available_licenses(d):
260 """
261 Return the available licenses by searching the directories specified by
262 COMMON_LICENSE_DIR and LICENSE_PATH.
263 """
264 lic_dirs = ((d.getVar('COMMON_LICENSE_DIR') or '') + ' ' +
265 (d.getVar('LICENSE_PATH') or '')).split()
266
267 licenses = []
268 for lic_dir in lic_dirs:
269 licenses += os.listdir(lic_dir)
270
271 licenses = sorted(licenses)
272 return licenses
273
274# Only determine the list of all available licenses once. This assumes that any
275# additions to LICENSE_PATH have been done before this file is parsed.
276AVAILABLE_LICENSES := "${@' '.join(available_licenses(d))}"
277
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500278def expand_wildcard_licenses(d, wildcard_licenses):
279 """
Andrew Geissler82c905d2020-04-13 13:39:40 -0500280 Return actual spdx format license names if wildcards are used. We expand
281 wildcards from SPDXLICENSEMAP flags and AVAILABLE_LICENSES.
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500282 """
283 import fnmatch
Andrew Geissler90fd73c2021-03-05 15:25:55 -0600284
285 # Assume if we're passed "GPLv3" or "*GPLv3" it means -or-later as well
286 for lic in wildcard_licenses[:]:
287 if not lic.endswith(("-or-later", "-only", "*")):
288 wildcard_licenses.append(lic + "+")
289
Brad Bishop15ae2502019-06-18 21:44:24 -0400290 licenses = wildcard_licenses[:]
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500291 spdxmapkeys = d.getVarFlags('SPDXLICENSEMAP').keys()
292 for wld_lic in wildcard_licenses:
293 spdxflags = fnmatch.filter(spdxmapkeys, wld_lic)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500294 licenses += [d.getVarFlag('SPDXLICENSEMAP', flag) for flag in spdxflags]
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500295
Andrew Geissler82c905d2020-04-13 13:39:40 -0500296 spdx_lics = d.getVar('AVAILABLE_LICENSES').split()
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500297 for wld_lic in wildcard_licenses:
298 licenses += fnmatch.filter(spdx_lics, wld_lic)
299
300 licenses = list(set(licenses))
301 return licenses
302
303def incompatible_license_contains(license, truevalue, falsevalue, d):
304 license = canonical_license(d, license)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500305 bad_licenses = (d.getVar('INCOMPATIBLE_LICENSE') or "").split()
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500306 bad_licenses = expand_wildcard_licenses(d, bad_licenses)
307 return truevalue if license in bad_licenses else falsevalue
308
Brad Bishopf3f93bb2019-10-16 14:33:32 -0400309def incompatible_pkg_license(d, dont_want_licenses, license):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500310 # Handles an "or" or two license sets provided by
311 # flattened_licenses(), pick one that works if possible.
312 def choose_lic_set(a, b):
Andrew Geissler82c905d2020-04-13 13:39:40 -0500313 return a if all(oe.license.license_ok(canonical_license(d, lic),
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500314 dont_want_licenses) for lic in a) else b
315
316 try:
317 licenses = oe.license.flattened_licenses(license, choose_lic_set)
318 except oe.license.LicenseError as exc:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500319 bb.fatal('%s: %s' % (d.getVar('P'), exc))
Andrew Geissler82c905d2020-04-13 13:39:40 -0500320
321 incompatible_lic = []
322 for l in licenses:
323 license = canonical_license(d, l)
324 if not oe.license.license_ok(license, dont_want_licenses):
325 incompatible_lic.append(license)
326
327 return sorted(incompatible_lic)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500328
Brad Bishopf3f93bb2019-10-16 14:33:32 -0400329def incompatible_license(d, dont_want_licenses, package=None):
330 """
331 This function checks if a recipe has only incompatible licenses. It also
332 take into consideration 'or' operand. dont_want_licenses should be passed
333 as canonical (SPDX) names.
334 """
335 import oe.license
336 license = d.getVar("LICENSE_%s" % package) if package else None
337 if not license:
338 license = d.getVar('LICENSE')
339
340 return incompatible_pkg_license(d, dont_want_licenses, license)
341
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500342def check_license_flags(d):
343 """
344 This function checks if a recipe has any LICENSE_FLAGS that
345 aren't whitelisted.
346
Brad Bishop19323692019-04-05 15:28:33 -0400347 If it does, it returns the all LICENSE_FLAGS missing from the whitelist, or
348 all of the LICENSE_FLAGS if there is no whitelist.
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500349
350 If everything is is properly whitelisted, it returns None.
351 """
352
353 def license_flag_matches(flag, whitelist, pn):
354 """
355 Return True if flag matches something in whitelist, None if not.
356
357 Before we test a flag against the whitelist, we append _${PN}
358 to it. We then try to match that string against the
359 whitelist. This covers the normal case, where we expect
360 LICENSE_FLAGS to be a simple string like 'commercial', which
361 the user typically matches exactly in the whitelist by
362 explicitly appending the package name e.g 'commercial_foo'.
363 If we fail the match however, we then split the flag across
364 '_' and append each fragment and test until we either match or
365 run out of fragments.
366 """
367 flag_pn = ("%s_%s" % (flag, pn))
368 for candidate in whitelist:
369 if flag_pn == candidate:
370 return True
371
372 flag_cur = ""
373 flagments = flag_pn.split("_")
374 flagments.pop() # we've already tested the full string
375 for flagment in flagments:
376 if flag_cur:
377 flag_cur += "_"
378 flag_cur += flagment
379 for candidate in whitelist:
380 if flag_cur == candidate:
381 return True
382 return False
383
384 def all_license_flags_match(license_flags, whitelist):
Brad Bishop19323692019-04-05 15:28:33 -0400385 """ Return all unmatched flags, None if all flags match """
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500386 pn = d.getVar('PN')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500387 split_whitelist = whitelist.split()
Brad Bishop19323692019-04-05 15:28:33 -0400388 flags = []
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500389 for flag in license_flags.split():
390 if not license_flag_matches(flag, split_whitelist, pn):
Brad Bishop19323692019-04-05 15:28:33 -0400391 flags.append(flag)
392 return flags if flags else None
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500393
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500394 license_flags = d.getVar('LICENSE_FLAGS')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500395 if license_flags:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500396 whitelist = d.getVar('LICENSE_FLAGS_WHITELIST')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500397 if not whitelist:
Brad Bishop19323692019-04-05 15:28:33 -0400398 return license_flags.split()
399 unmatched_flags = all_license_flags_match(license_flags, whitelist)
400 if unmatched_flags:
401 return unmatched_flags
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500402 return None
403
404def check_license_format(d):
405 """
406 This function checks if LICENSE is well defined,
407 Validate operators in LICENSES.
408 No spaces are allowed between LICENSES.
409 """
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500410 pn = d.getVar('PN')
411 licenses = d.getVar('LICENSE')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500412 from oe.license import license_operator, license_operator_chars, license_pattern
413
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600414 elements = list(filter(lambda x: x.strip(), license_operator.split(licenses)))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500415 for pos, element in enumerate(elements):
416 if license_pattern.match(element):
417 if pos > 0 and license_pattern.match(elements[pos - 1]):
418 bb.warn('%s: LICENSE value "%s" has an invalid format - license names ' \
419 'must be separated by the following characters to indicate ' \
420 'the license selection: %s' %
421 (pn, licenses, license_operator_chars))
422 elif not license_operator.match(element):
423 bb.warn('%s: LICENSE value "%s" has an invalid separator "%s" that is not ' \
424 'in the valid list of separators (%s)' %
425 (pn, licenses, element, license_operator_chars))
426
427SSTATETASKS += "do_populate_lic"
428do_populate_lic[sstate-inputdirs] = "${LICSSTATEDIR}"
429do_populate_lic[sstate-outputdirs] = "${LICENSE_DIRECTORY}/"
430
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800431IMAGE_CLASSES_append = " license_image"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500432
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500433python do_populate_lic_setscene () {
434 sstate_setscene(d)
435}
436addtask do_populate_lic_setscene