blob: f06e00d70d7eaf0f8ddc3aa6615d79b549e64c94 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001# reproducible_build.bbclass
2#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08003# Sets SOURCE_DATE_EPOCH in each component's build environment.
4# Upstream components (generally) respect this environment variable,
5# using it in place of the "current" date and time.
6# See https://reproducible-builds.org/specs/source-date-epoch/
Brad Bishop316dfdd2018-06-25 12:45:53 -04007#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008# After sources are unpacked but before they are patched, we set a reproducible value for SOURCE_DATE_EPOCH.
9# This value should be reproducible for anyone who builds the same revision from the same sources.
Brad Bishop316dfdd2018-06-25 12:45:53 -040010#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011# There are 4 ways we determine SOURCE_DATE_EPOCH:
Brad Bishop316dfdd2018-06-25 12:45:53 -040012#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013# 1. Use the value from __source_date_epoch.txt file if this file exists.
14# This file was most likely created in the previous build by one of the following methods 2,3,4.
15# Alternatively, it can be provided by a recipe via SRC_URI.
Brad Bishop316dfdd2018-06-25 12:45:53 -040016#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017# If the file does not exist:
18#
19# 2. If there is a git checkout, use the last git commit timestamp.
20# Git does not preserve file timestamps on checkout.
Brad Bishop316dfdd2018-06-25 12:45:53 -040021#
22# 3. Use the mtime of "known" files such as NEWS, CHANGLELOG, ...
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023# This works for well-kept repositories distributed via tarball.
Brad Bishop316dfdd2018-06-25 12:45:53 -040024#
Brad Bishopa5c52ff2018-11-23 10:55:50 +130025# 4. Use the modification time of the youngest file in the source tree, if there is one.
26# This will be the newest file from the distribution tarball, if any.
27#
28# 5. Fall back to a fixed timestamp.
Brad Bishop316dfdd2018-06-25 12:45:53 -040029#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030# Once the value of SOURCE_DATE_EPOCH is determined, it is stored in the recipe's SDE_FILE.
31# If none of these mechanisms are suitable, replace the do_deploy_source_date_epoch task
32# with recipe-specific functionality to write the appropriate SOURCE_DATE_EPOCH into the SDE_FILE.
33#
34# If this file is found by other tasks, the value is exported in the SOURCE_DATE_EPOCH variable.
35# SOURCE_DATE_EPOCH is set for all tasks that might use it (do_configure, do_compile, do_package, ...)
Brad Bishop316dfdd2018-06-25 12:45:53 -040036
37BUILD_REPRODUCIBLE_BINARIES ??= '1'
38inherit ${@oe.utils.ifelse(d.getVar('BUILD_REPRODUCIBLE_BINARIES') == '1', 'reproducible_build_simple', '')}
39
Andrew Geissler90fd73c2021-03-05 15:25:55 -060040SDE_DIR = "${WORKDIR}/source-date-epoch"
Brad Bishop316dfdd2018-06-25 12:45:53 -040041SDE_FILE = "${SDE_DIR}/__source_date_epoch.txt"
Brad Bishop00e122a2019-10-05 11:10:57 -040042SDE_DEPLOYDIR = "${WORKDIR}/deploy-source-date-epoch"
Brad Bishop316dfdd2018-06-25 12:45:53 -040043
Andrew Geissler90fd73c2021-03-05 15:25:55 -060044# A SOURCE_DATE_EPOCH of '0' might be misinterpreted as no SDE
45export SOURCE_DATE_EPOCH_FALLBACK ??= "1302044400"
46
Brad Bishop316dfdd2018-06-25 12:45:53 -040047SSTATETASKS += "do_deploy_source_date_epoch"
48
49do_deploy_source_date_epoch () {
Brad Bishop00e122a2019-10-05 11:10:57 -040050 mkdir -p ${SDE_DEPLOYDIR}
51 if [ -e ${SDE_FILE} ]; then
Andrew Geissler82c905d2020-04-13 13:39:40 -050052 echo "Deploying SDE from ${SDE_FILE} -> ${SDE_DEPLOYDIR}."
Brad Bishop00e122a2019-10-05 11:10:57 -040053 cp -p ${SDE_FILE} ${SDE_DEPLOYDIR}/__source_date_epoch.txt
Andrew Geissler82c905d2020-04-13 13:39:40 -050054 else
55 echo "${SDE_FILE} not found!"
Brad Bishop00e122a2019-10-05 11:10:57 -040056 fi
Brad Bishop316dfdd2018-06-25 12:45:53 -040057}
58
59python do_deploy_source_date_epoch_setscene () {
60 sstate_setscene(d)
Brad Bishop00e122a2019-10-05 11:10:57 -040061 bb.utils.mkdirhier(d.getVar('SDE_DIR'))
62 sde_file = os.path.join(d.getVar('SDE_DEPLOYDIR'), '__source_date_epoch.txt')
63 if os.path.exists(sde_file):
Andrew Geissler82c905d2020-04-13 13:39:40 -050064 target = d.getVar('SDE_FILE')
65 bb.debug(1, "Moving setscene SDE file %s -> %s" % (sde_file, target))
66 os.rename(sde_file, target)
67 else:
68 bb.debug(1, "%s not found!" % sde_file)
Brad Bishop316dfdd2018-06-25 12:45:53 -040069}
70
Brad Bishop00e122a2019-10-05 11:10:57 -040071do_deploy_source_date_epoch[dirs] = "${SDE_DEPLOYDIR}"
72do_deploy_source_date_epoch[sstate-plaindirs] = "${SDE_DEPLOYDIR}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040073addtask do_deploy_source_date_epoch_setscene
74addtask do_deploy_source_date_epoch before do_configure after do_patch
75
Andrew Geissler82c905d2020-04-13 13:39:40 -050076python create_source_date_epoch_stamp() {
Andrew Geisslerb7d28612020-07-24 16:15:54 -050077 import oe.reproducible
78
Brad Bishop316dfdd2018-06-25 12:45:53 -040079 epochfile = d.getVar('SDE_FILE')
Andrew Geissler82c905d2020-04-13 13:39:40 -050080 # If it exists we need to regenerate as the sources may have changed
Brad Bishop316dfdd2018-06-25 12:45:53 -040081 if os.path.isfile(epochfile):
Andrew Geissler82c905d2020-04-13 13:39:40 -050082 bb.debug(1, "Deleting existing SOURCE_DATE_EPOCH from: %s" % epochfile)
83 os.remove(epochfile)
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080084
Andrew Geisslerb7d28612020-07-24 16:15:54 -050085 source_date_epoch = oe.reproducible.get_source_date_epoch(d, d.getVar('S'))
Brad Bishop316dfdd2018-06-25 12:45:53 -040086
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080087 bb.debug(1, "SOURCE_DATE_EPOCH: %d" % source_date_epoch)
Brad Bishop316dfdd2018-06-25 12:45:53 -040088 bb.utils.mkdirhier(d.getVar('SDE_DIR'))
89 with open(epochfile, 'w') as f:
90 f.write(str(source_date_epoch))
91}
92
Andrew Geissler82c905d2020-04-13 13:39:40 -050093def get_source_date_epoch_value(d):
94 cached = d.getVar('__CACHED_SOURCE_DATE_EPOCH')
95 if cached:
96 return cached
97
98 epochfile = d.getVar('SDE_FILE')
Andrew Geissler90fd73c2021-03-05 15:25:55 -060099 source_date_epoch = int(d.getVar('SOURCE_DATE_EPOCH_FALLBACK'))
Andrew Geissler82c905d2020-04-13 13:39:40 -0500100 if os.path.isfile(epochfile):
101 with open(epochfile, 'r') as f:
102 s = f.read()
103 try:
104 source_date_epoch = int(s)
Andrew Geissler90fd73c2021-03-05 15:25:55 -0600105 # workaround for old sstate with SDE_FILE content being 0 - use SOURCE_DATE_EPOCH_FALLBACK
106 if source_date_epoch == 0 :
107 source_date_epoch = int(d.getVar('SOURCE_DATE_EPOCH_FALLBACK'))
108 bb.warn("SOURCE_DATE_EPOCH value from sstate '%s' is deprecated/invalid. Reverting to SOURCE_DATE_EPOCH_FALLBACK '%s'" % (s, source_date_epoch))
Andrew Geissler82c905d2020-04-13 13:39:40 -0500109 except ValueError:
Andrew Geissler90fd73c2021-03-05 15:25:55 -0600110 bb.warn("SOURCE_DATE_EPOCH value '%s' is invalid. Reverting to SOURCE_DATE_EPOCH_FALLBACK" % s)
111 source_date_epoch = int(d.getVar('SOURCE_DATE_EPOCH_FALLBACK'))
Andrew Geissler82c905d2020-04-13 13:39:40 -0500112 bb.debug(1, "SOURCE_DATE_EPOCH: %d" % source_date_epoch)
113 else:
114 bb.debug(1, "Cannot find %s. SOURCE_DATE_EPOCH will default to %d" % (epochfile, source_date_epoch))
115
116 d.setVar('__CACHED_SOURCE_DATE_EPOCH', str(source_date_epoch))
117 return str(source_date_epoch)
118
119export SOURCE_DATE_EPOCH ?= "${@get_source_date_epoch_value(d)}"
Brad Bishop316dfdd2018-06-25 12:45:53 -0400120BB_HASHBASE_WHITELIST += "SOURCE_DATE_EPOCH"
121
122python () {
123 if d.getVar('BUILD_REPRODUCIBLE_BINARIES') == '1':
Andrew Geissler82c905d2020-04-13 13:39:40 -0500124 d.appendVarFlag("do_unpack", "postfuncs", " create_source_date_epoch_stamp")
Brad Bishop316dfdd2018-06-25 12:45:53 -0400125}