blob: 50c79b3bf00a3bf176319642b229687a1485ea7e [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "The Bitstream Vera fonts - TTF Edition"
2DESCRIPTION = "The Bitstream Vera fonts include four monospace and sans \
3faces (normal, oblique, bold, bold oblique) and two serif faces (normal \
4and bold). In addition Fontconfig/Xft2 can artificially oblique the \
5serif faces for you: this loses hinting and distorts the faces slightly, \
6but is visibly different than normal and bold, and reasonably pleasing."
7SECTION = "x11/fonts"
8LICENSE = "BitstreamVera"
9LIC_FILES_CHKSUM = "file://COPYRIGHT.TXT;md5=27d7484b1e18d0ee4ce538644a3f04be"
Andrew Geissler90fd73c2021-03-05 15:25:55 -060010PR = "r8"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
Andrew Geissler635e0e42020-08-21 15:58:33 -050012inherit allarch fontcache
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013
Andrew Geissler90fd73c2021-03-05 15:25:55 -060014# remove at next version upgrade or when output changes
15HASHEQUIV_HASH_VERSION .= ".1"
16
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017FONT_PACKAGES = "${PN}"
18
Brad Bishop316dfdd2018-06-25 12:45:53 -040019SRC_URI = "${GNOME_MIRROR}/ttf-bitstream-vera/1.10/ttf-bitstream-vera-${PV}.tar.bz2"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020SRC_URI[md5sum] = "bb22bd5b4675f5dbe17c6963d8c00ed6"
21SRC_URI[sha256sum] = "db5b27df7bbb318036ebdb75acd3e98f1bd6eb6608fb70a67d478cd243d178dc"
Brad Bishop316dfdd2018-06-25 12:45:53 -040022
23do_install () {
24 install -d ${D}${datadir}/fonts/ttf
25 for i in *.ttf; do
26 install -m 644 $i ${D}${datadir}/fonts/ttf
27 done
28
29 install -d ${D}${docdir}/${BPN}
30 for i in *.TXT; do
31 install -m 644 $i ${D}${docdir}/${BPN}
32 done
33}
34
35FILES_${PN} = "${datadir}/fonts"