blob: d37ad00cf8ce005d783b7f5fe765297d30613f9d [file] [log] [blame]
Andrew Geisslerd1e89492021-02-12 15:35:20 -06001inherit features_check
2REQUIRED_DISTRO_FEATURES = "ptest"
3
Brad Bishopc342db32019-05-15 21:57:59 -04004require core-image-sato-sdk.bb
5require conf/distro/include/ptest-packagelists.inc
6
7IMAGE_INSTALL += "${PTESTS_FAST}"
8
9DESCRIPTION += "Also includes ptest packages with fast execution times to allow for more automated QA."
Andrew Geissler90fd73c2021-03-05 15:25:55 -060010HOMEPAGE = "https://www.yoctoproject.org/"
Brad Bishopc342db32019-05-15 21:57:59 -040011
12# This image is sufficiently large (~1.8GB) that it can't actually fit in a live
13# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
14# box) and explicitly add just 1500MB.
15# strace-ptest in particular needs more than 500MB
16IMAGE_OVERHEAD_FACTOR = "1.0"
17IMAGE_ROOTFS_EXTRA_SPACE = "1524288"
18
19# ptests need more memory than standard to avoid the OOM killer
20QB_MEM = "-m 1024"
Andrew Geissler82c905d2020-04-13 13:39:40 -050021
22# Sadly at the moment the fast set of ptests is not robust enough and sporadically fails in a couple of places
23PTEST_EXPECT_FAILURE = "1"